Support Questions

Find answers, ask questions, and share your expertise

Problem with spark2 CSD

I've had a problem with the Spark2 CSD, while trying to install it on our cluster the following error rises when trying to start the history server:
"This role requires the following additional parcels to be activated before it can start[spark2]"




You need to add the Spark2 remote parcel URL to Cloudera Manager. After that you should have the option to download it and distribute it to the cluster.

I will elaborate further:

We have a cluster that has been recently upgraded to CDH 5.11.1

we tried to reinstall the spark2 CSD after the upgrade and received the following error while trying to redeploy client configuration:

"This role requires the following additional parcels to be activated before it can start[spark2]"

The version of the spark2 we are trying to install is 2.2.0.

The spark2 parcel is downloaded and activated across the cluster so that isnt the problem.

We have another cluster that was also recently upgraded to CDH 5.11.1 and spark2 was succesfully installed there.

The only difference I can think of between the clusters is that one (The one that the installation failed on) of them is managed inside a cloudera manager server that has 3 clusters in it (without the cloudera management service)


and the cluster that the SPARK2 installation was working on is the only cluster inside the cloudera manager serrver that manages it.


New Contributor

I'm trying to install Spark2 in my cloudera cluster (evaluation version) following the cloudera's instructions to install this component. I downloaded the CSD, instaled it and using the parcel downloaded the component, distribute it but when I try to activate it I'm having this message:
CDH (5.8 and higher) parcel required for SPARK2 (2.2.0.cloudera1-1.cdh5.12.0.p0.142354) is not available.


This is the information of the cluster:
Version: Cloudera Enterprise Data Hub Edition Trial 5.12.1 (#6 built by jenkins on 20170818-0807 git: 9bdee611802535491d400e03c98ef694a2c77d0a)
Java VM Name: Java HotSpot(TM) 64-Bit Server VM
Java VM Vendor: Oracle Corporation
Java Version: 1.7.0_67

I'm thinking it could be because my CDH version (5.12.1) and the version of the last spark2 parcel (cdh5.12.0) but I don't find any other package for cdh5.12.1 and my next question is: for cdh5.13.0 which is the spark2 parcel?

Cloudera installed jdk 1.7 by default but I change the jvm version of all hosts to the jdk 1.8, so all applications are running over jdk 1.8 and just the cloudera manager is running with jdk 1.7 (last time I tried to change de version, the cluster just crash, this why I just change version for host and not fo cloudera manager) ... I'm not sure what java version its taken by default in an instalation, I suppose it take the java version defined in the host (in my case 1.8)

Cloudera Employee

Spark2 requires JDK 8


I had the same issue on quickstart 5.12.0, after upgrading JDK and CDH to 5.12.1, I was able to activate spark2.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.