Support Questions
Find answers, ask questions, and share your expertise

Proxy error while starting services in Ambari 2.2

I'm trying to set up a single-node Hadoop cluster (HDP2.3 version) using Ambari 2.2 in Eucalyptus environment.

I have used Private IP address as recommended while registering the VM's (RHEL 6.5) with Ambari.

When I tried to bring up Hadoop services (MR2, Hive, Yarn) , I'm getting the below error:

 <LI id=L_11001_11>Error Code 11001: Host not found
<LI id=L_11001_12>Background: This error indicates that
the gateway could not find the IP address of the website you are trying to
access. This is usually due to a DNS-related error.
<LI id=L_11001_13>Date: 2/9/2016 5:57:11 AM [GMT]
<LI id=L_11001_14>Server: FIESPRX004.xxx.net
<LI id=L_11001_15>Source: DNS error
</UL>
1 ACCEPTED SOLUTION

12 REPLIES 12

Mentor

@Phoncy Joseph

Please have a look at dns configuration for Eucalyptus

Thanks for the response. I have set no proxy for local addresses in the host machine using export no_proxy from the command line. Below is the command that fails while starting the service:

resource_management.core.exceptions.Fail: Execution of 'curl -sS -L -w '%{http_code}' -X GET 'http://fqdn:50070/webhdfs/v1/app-logs?op=GETFILESTATUS&user.name=hdfs'' returned status_code=502.

@Phoncy Joseph Bad Gateway request. Are you able to run this? telnet fqdn 50070 ?

Yes, it says connected.

Setting no proxy for the fqdn in /etc/profile solved the issue. Thanks.

@Phoncy Joseph

Please accept one of the answers to close the thread.

Mentor

what is your JDK version with Ambari 2.2? I'm wondering if you're hitting this https://issues.apache.org/jira/browse/AMBARI-14778 @Phoncy Joseph

The JDK version is 1.6.0

Mentor

Ambari 2.2 does not support JDK 1.6, upgrade to latest 1.7 or 1.8 @Phoncy Joseph

read the docs http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.0.0/bk_upgrading_Ambari/content/_preparing_to_up...

Noted. Thank you.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.