Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ranger KMS won't start

Solved Go to solution
Highlighted

Ranger KMS won't start

New Contributor
2015-10-01 21:00:14,475 - File['/etc/ranger/kms/rangerkms.jceks'] {'owner': 'kms', 'group': 'kms'}
2015-10-01 21:00:14,476 - XmlConfig['dbks-site.xml'] {'group': 'kms', 'conf_dir': '/usr/hdp/current/ranger-kms/conf', 'mode': 0644, 'configuration_attributes': {}, 'owner': 'kms', 'configurations': ...}
2015-10-01 21:00:14,494 - Generating config: /usr/hdp/current/ranger-kms/conf/dbks-site.xml
2015-10-01 21:00:14,495 - File['/usr/hdp/current/ranger-kms/conf/dbks-site.xml'] {'owner': 'kms', 'content': InlineTemplate(...), 'group': 'kms', 'mode': 0644, 'encoding': 'UTF-8'}
2015-10-01 21:00:14,505 - Writing File['/usr/hdp/current/ranger-kms/conf/dbks-site.xml'] because contents don't match
2015-10-01 21:00:14,506 - XmlConfig['ranger-kms-site.xml'] {'group': 'kms', 'conf_dir': '/usr/hdp/current/ranger-kms/conf', 'mode': 0644, 'configuration_attributes': {}, 'owner': 'kms', 'configurations': ...}
2015-10-01 21:00:14,520 - Generating config: /usr/hdp/current/ranger-kms/conf/ranger-kms-site.xml
2015-10-01 21:00:14,520 - File['/usr/hdp/current/ranger-kms/conf/ranger-kms-site.xml'] {'owner': 'kms', 'content': InlineTemplate(...), 'group': 'kms', 'mode': 0644, 'encoding': 'UTF-8'}
2015-10-01 21:00:14,527 - Writing File['/usr/hdp/current/ranger-kms/conf/ranger-kms-site.xml'] because contents don't match
2015-10-01 21:00:14,527 - XmlConfig['kms-site.xml'] {'group': 'kms', 'conf_dir': '/usr/hdp/current/ranger-kms/conf', 'mode': 0644, 'configuration_attributes': {}, 'owner': 'kms', 'configurations': ...}
2015-10-01 21:00:14,541 - Generating config: /usr/hdp/current/ranger-kms/conf/kms-site.xml
2015-10-01 21:00:14,541 - File['/usr/hdp/current/ranger-kms/conf/kms-site.xml'] {'owner': 'kms', 'content': InlineTemplate(...), 'group': 'kms', 'mode': 0644, 'encoding': 'UTF-8'}
2015-10-01 21:00:14,556 - Writing File['/usr/hdp/current/ranger-kms/conf/kms-site.xml'] because contents don't match
2015-10-01 21:00:14,556 - File['/usr/hdp/current/ranger-kms/conf/kms-log4j.properties'] {'content': ..., 'owner': 'kms', 'group': 'kms', 'mode': 0644} 

2015-10-01 21:01:17,660 - Error : [Errno 110] Connection timed out

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Ranger KMS won't start

You showed this error:

Error : [Errno 110] Connection timed out

That means the Ranger KMS services cannot reach the Ranger Admin service (http://rangeradminhost:6080).

Verify that "External URL" is set properly for Ranger & Ranger KMS. Typically it's `http://hostnameofrangeradmin:6080`

Common mistakes I've seen:

  • Putting a `/` on the end. It won't work with this.
  • Using a hostname which is not resolvable internally between all of the hosts. (The name "External URL" is confusing since it's really the "Internal URL")
    • Such as setting to `http://localhost:6080` which will only work from the Ranger Admin host
4 REPLIES 4

Re: Ranger KMS won't start

Don't see an error here. Can you check logs in /var/log/ranger/kms/?

Re: Ranger KMS won't start

Error is:

2015-10-01 21:01:17,660 - Error : [Errno 110] Connection timed out

Re: Ranger KMS won't start

You showed this error:

Error : [Errno 110] Connection timed out

That means the Ranger KMS services cannot reach the Ranger Admin service (http://rangeradminhost:6080).

Verify that "External URL" is set properly for Ranger & Ranger KMS. Typically it's `http://hostnameofrangeradmin:6080`

Common mistakes I've seen:

  • Putting a `/` on the end. It won't work with this.
  • Using a hostname which is not resolvable internally between all of the hosts. (The name "External URL" is confusing since it's really the "Internal URL")
    • Such as setting to `http://localhost:6080` which will only work from the Ranger Admin host

Re: Ranger KMS won't start

The KMS is also backed by a DB. Make sure kms db user/host combination has been granted permissions in MySQL (if that's what you're using).