Support Questions
Find answers, ask questions, and share your expertise

Ranger not Enable from HIVE

Solved Go to solution

Ranger not Enable from HIVE

Explorer

When I enable the Ranger Service from HIVE in Cloudera Manager, it's getting an error like:

"Hive Impersonation is enabled for Hive Server2 role 'HiveServer2 (node1)'. Hive Impersonation should be disabled to enable Hive authorization using Ranger"

I want to access control from Ranger, But I cant 
Anybody, please help me.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Ranger not Enable from HIVE

Cloudera Employee

@sujonict07 

 

Can you try to disable the Hive impersonation?  If impersonation is enabled then all your hive queries will run as hive user and hive is super user for hive service which wouldn't be a good setup as you may want to restrict access to some users.

 

When you disable the hive impersonation then all queries will be submitted by the actual user and ranger will be able to provide the authorisation.

 

If it is enabled it doesn't make sense to use ranger.

 

Are you using CDP?

 

 

View solution in original post

1 REPLY 1
Highlighted

Re: Ranger not Enable from HIVE

Cloudera Employee

@sujonict07 

 

Can you try to disable the Hive impersonation?  If impersonation is enabled then all your hive queries will run as hive user and hive is super user for hive service which wouldn't be a good setup as you may want to restrict access to some users.

 

When you disable the hive impersonation then all queries will be submitted by the actual user and ranger will be able to provide the authorisation.

 

If it is enabled it doesn't make sense to use ranger.

 

Are you using CDP?

 

 

View solution in original post

Don't have an account?