Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Ranger service is failing to install

avatar

Ranger service is failing to install with below error

 

Error executing: CREATE FUNCTION `getXportalUIdByLoginId`(input_val VARCHAR(100)) RETURNS int(11) BEGIN DECLARE myid INT; SELECT x_portal_user.id into myid FROM x_portal_user WHERE x_portal_user.login_id = input_val; RETURN myid; END
java.sql.SQLException: This function has none of DETERMINISTIC, NO SQL, or READS SQL DATA in its declaration and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable)
SQLException : SQL state: HY000 java.sql.SQLException: This function has none of DETERMINISTIC, NO SQL, or READS SQL DATA in its declaration and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators variable) ErrorCode: 1418
2021-01-19 10:13:39,544 [E] ranger_core_db_mysql.sql file import failed!

2 ACCEPTED SOLUTIONS

avatar
Master Collaborator

@Harish-hadoop  try setting log_bin_trust_function_creators = 1 by using the below command in ranger db and retry installing the ranger service 

# SET GLOBAL log_bin_trust_function_creators = 1 

 

View solution in original post

avatar

Thanks a lot @Scharan this solution worked perfectly

View solution in original post

2 REPLIES 2

avatar
Master Collaborator

@Harish-hadoop  try setting log_bin_trust_function_creators = 1 by using the below command in ranger db and retry installing the ranger service 

# SET GLOBAL log_bin_trust_function_creators = 1 

 

avatar

Thanks a lot @Scharan this solution worked perfectly