Support Questions
Find answers, ask questions, and share your expertise

Register new version problem 2.4.0 2.0 CENTOS 7.0

Hi guys,

I try to register a new version using the wizard of ambari. Versions-> Register Version details - HDP 2.4. 2.0

I mark the redhat 7 check (I using centos)

HDP- http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0/

HDP-UTILS http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/

The message that generate was

Some of the repositories failed validation. Make changes to the base url or skip validation if you are sure that urls are correct

Any ideas I like to past form HDP-2.3.4.0 to HDP-2.4.2.0

I have acces permanely to internet using a proxy and I can download from external repos.

Thanks you in avance

6 REPLIES 6

Rising Star

It may be a proxy issue. try to download the repos, update your HDP.repo & HDP-UTILS.repo ( under /etc/yum.repos.d/ ) to point to both old and new repo, check with "yum info ranger" for example, it should detect both packages then in ambari use local path instead.

PS : you can make the repo available also locally through http, you will find a script within the repos that you can run, it install httpd and put the repo accessible under ../html/www/

Hi,

I download the repo using

wget -nv http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0/hdp.repo -O /etc/yum.repos.d/hdp.repo

wget -nv http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0/hdp.repo -O /etc/yum.repos.d/hdp.repo 2017-01-23 12:09:50 URL:http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0/hdp.repo [575/575] -> "/etc/yum.repos.d/hdp.repo" [1]

I launch the comand yum info ranger

Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirror.mhd.uk.as44574.net * epel: epel.besthosting.ua * extras: anorien.csc.warwick.ac.uk * updates: anorien.csc.warwick.ac.uk Error: No matching Packages to list

I think that I do not donload the correct repo file ?

Rising Star

Yes i think you didn't download them correctly,

check what's inside /etc/yum.repos.d/hdp.repo ?

try yum clean all

I made a more of the hdp.repo file

more hdp.repo

#VERSION_NUMBER=2.4.2.0-258

[HDP-2.4.2.0]

name=HDP Version - HDP-2.4.2.0

baseurl=http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0

gpgcheck=1

gpgkey=http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins enabled=1

priority=1

[HDP-UTILS-1.1.0.20]

name=HDP Utils Version - HDP-UTILS-1.1.0.20

baseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos7

gpgcheck=1

gpgkey=http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins enabled=1

priority=1

I made a yum clean all and a yum clean metada and the result is similar

Determining fastest mirrors * base: anorien.csc.warwick.ac.uk * epel: epel.besthosting.ua * extras: anorien.csc.warwick.ac.uk * updates: centos.mirroring.pulsant.co.uk Error: No matching Packages to list

Rising Star

your repo is still pointing to the public one.

Please change it to the local one

i.e

baseurl=/lLOCALSERVER/HDP-UTILS-1.1.0.20/repos/centos7

change it according to your path.

In try to install form public one.

You suggest that i cannot install from a public repo and only I could install for a local repo or a localhost repo.