Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Repo base url invalid while registering HDP VERSION 2.6.5.

Highlighted

Repo base url invalid while registering HDP VERSION 2.6.5.

New Contributor

I am trying to upgrade HDP2.5.3 to HDP 2.6.5.

  1. To setup local repository with no internet access i have taken following steps:
  • download and extracted tar file for HDP 2.6.5 , HDP_UTLIS, HDP-GPL in the node hosting ambari server.
  • downloaded hdp.repo and hdp.gpl.repo file in all the host and changed base url.

2. now while registering version in ambari base url for HDP 2.6, HDP-UTILS, HDP-2.6-GPL failed validation.

baseurl for HDP 2.6 = http://slnxhadoop01.noid.in/hdp/HDP/centos7/2.6.5.0-292

HDP-2.6-GPL = http://slnxhadoop01.noid.in/hdp/HDP-UTILS/centos7/1.1.0.22/

HDP-UTILS-1.1.0.22 = http://slnxhadoop01.noid.in/hdp/HDP-GPL/centos7/2.6.5.0-292/

ambari-baseurl-validation.pnghdp-265-repo.pnghdp-gpl-repo.pnghdp-utils-repo.png

2 REPLIES 2

Re: Repo base url invalid while registering HDP VERSION 2.6.5.

Super Mentor

@Shobhna Dhami

From Ambari Server host please check if you are able to make the following curl calls to verify if the repos are properly accessible from Ambari Host or not? Or if there is any "/etc/hosts" entry issue :

# curl -iv http://slnxhadoop01.noid.in/hdp/HDP/centos7/2.6.5.0-292/repodata/repomd.xml
# curl -iv http://slnxhadoop01.noid.in/hdp/HDP-UTILS/centos7/1.1.0.22/repodata/repomd.xml
# curl -iv http://slnxhadoop01.noid.in/hdp/HDP-GPL/centos7/2.6.5.0-292/repodata/repomd.xml

.

Also from ambari server host please verify if the Host is accessible and the mentioned XML file can be downloaded?

Re: Repo base url invalid while registering HDP VERSION 2.6.5.

New Contributor

@Jay Kumar SenSharma Thanks for the reply.

slnxhadoop01.noid.in is ambari server host and i am able to make successful curl calls and download xml file.

For setting local repository for HDP 2.3.5.0 , I deleted existing HDP.repo file for HDP 2.5.3.0 and created new HDP.repo file for HDP version 2.6.5.0.

I am able to register HDP 2.6.5.0 but while installing getting error:

stderr: /var/lib/ambari-agent/data/errors-3360.txt

2018-09-07 14:46:16,114 - Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install mahout' returned 1.  One of the configured repositories failed (HDP-2.5.3.0-37),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable HDP-2.5.3.0-37

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=HDP-2.5.3.0-37.skip_if_unavailable=true

failure: repodata/repomd.xml from HDP-2.5.3.0-37: [Errno 256] No more mirrors to try.
http://slnxhadoop01.noid.in.sopra/hdp/HDP/centos7/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 423, in install_packages
    retry_count=agent_stack_retry_count
  File "/usr/lib/ambari-agent/lib/resource_management/core/base.py", line 166, in __init__
    self.env.run()
  File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 124, in run_action
    provider_action()
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/__init__.py", line 57, in action_upgrade
    self.upgrade_package(package_name, self.resource.use_repos, self.resource.skip_repos)
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/yumrpm.py", line 269, in upgrade_package
    return self.install_package(name, use_repos, skip_repos, is_upgrade)
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/yumrpm.py", line 264, in install_package
    self.checked_call_with_retries(cmd, sudo=True, logoutput=self.get_logoutput())
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/__init__.py", line 266, in checked_call_with_retries
    return self._call_with_retries(cmd, is_checked=True, **kwargs)
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/__init__.py", line 283, in _call_with_retries
    code, out = func(cmd, **kwargs)
  File "/usr/lib/ambari-agent/lib/resource_management/core/shell.py", line 72, in inner
    result = function(command, **kwargs)
  File "/usr/lib/ambari-agent/lib/resource_management/core/shell.py", line 102, in checked_call
    tries=tries, try_sleep=try_sleep, timeout_kill_strategy=timeout_kill_strategy)
  File "/usr/lib/ambari-agent/lib/resource_management/core/shell.py", line 150, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/ambari-agent/lib/resource_management/core/shell.py", line 303, in _call
    raise ExecutionFailed(err_msg, code, out, err)
Don't have an account?
Coming from Hortonworks? Activate your account here