Support Questions

Find answers, ask questions, and share your expertise

Run Zeppelin as zeppelin user and not as root

Hi everyone,

I Installed a standalone Zeppelin on a HDP 2.5 – That means, I have one Ambari managed Zeppelin (0.6.X) which comes with HDP and an extra Zeppelin 0.7.3 that I installed manually.

I installed it on /opt/zeppelin and I set the ownership to zeppelin:zeppelin and permissions to 775

If I started the Zeppelin with the zeppelin user the Webapps directory is empty (even when no error message is thrown and zeppelin status is running). Therefore I get a 403 error (powered by jetty) when I try to open the Web UI.

If I start Zeppelin as root everything works, but according to the Documentation Zeppelin must be started with the zeppelin user.

I also would like to avoid the use of the root user.

Any Idea or comment will be appreciated.

Kind regards,



Super Mentor

@Paul Hernandez

When you mentioned that you have installed an extra Zeppelin 0.7.3 that I installed manually, Does it mean that you installed it on your own Instead of Ambari managed way?


Usually ambari takes care of setting all the required permission and required user (zeppelin) creation and adding correct group to the user.

However when you are managing it on your own then you will need to manually check all those permissions and configurations.


So if you want to start Zeppelin as "zeppelin" process then please let us know what error/exception are you getting so that it can be investigated separately outside standard Ambari managed Zeppelin way.

Hi Jay,

thanks for the quick answer. I installed without Ambari. The reason: I want to use Spark2 which is not working with Zeppelin 0.6. I need Zeppelin 0.7.x which is not working with Ambari 2.4. I cannot or at least I don't want at this moment to upgrade our HDP 2.5.3

In this chain of dependencies I found the best solution to install a non Ambari managed Zeppelin.

When I started Zeppelin in this way:

su zeppelin
/opt/zeppelin/bin/ start

I got no errors.

When I navigate to http://myhost:9995 I got an HTTP 403 - forbidden

What I saw, is the directory /opt/zeppelin/webapps is empty.

If I do the same as root the directory above is populated /opt/zeppelin/Webapps/webapp/.....

Therefore I guess is a permission problem, but I already set the permissions as follows:

chown -R zeppelin:zeppelin /opt/zeppelin
chmod -R 775 /opt/zeppelin