Support Questions

Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

SAM SchemaMetadata not found with the schemaName error

New Contributor

I am trying to follow the steps at https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.0.0/bk_getting-started-with-stream-analytics/co...

by creating a new kafka topic, then adding a new schema in the SchemaRegistry. However, when I try to add a new schema (following the instructions on the page) I get the following error when I click on Save in Schema Registry:

An exception was thrown while processing request with message: [SchemaMetadata not found with the schemaName: raw-truck_events_avro]

I am a newbie with this tool - so I don't know where to look next to see what is causing this error.

Your help is greatly appreciated!

1 ACCEPTED SOLUTION

Contributor

Are your schema Name and topic name Same(literally)?

View solution in original post

2 REPLIES 2

Contributor

Are your schema Name and topic name Same(literally)?

New Contributor

I had to go into Postgres and delete my first attempt from schema_version_info - and that was apparently blocking all additional schemas from being added (and causing the UI to hang).

I just tried with the name in schema registry and the "name" in the schema matching the topic name - and it worked!

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.