Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
03-28-2023
06:51 PM
- last edited on
04-21-2026
12:16 AM
by
GrazittiAPI
Hi Community Team,
I have a Private Cloud Base Platform 7.1.7.SP1 with hive 3.1. I need to connect my SAP server (Windows server) to hive. I installed Cloudera ODBC driver 2.6.13 and when I configured the DSN, shows me an error
"ERROR 1100 SSL certificate verification failed because the certificate is missing or incorrect.
- I have the AUTO TLS/SSL installed in the cluster. Hive has enabled TLS/SSL.
My Questions:
- How I generate a certificate .jks to this server that is not part of the cluster CDP.
- What other steps I do to resolve this.
Thank for your support.
Created 03-29-2023 01:00 PM
Another Question: other option can be Install jdbc?
Created 03-29-2023 04:47 PM
I tried to recreate your scenarion using HDP and ODBC
ODBC screens
I created a hive database and table and used a non ssl connection as shown below as my HDP is not Secured, though the ODBS delivers a certificate in C:\Program Files\Cloudera ODBC Driver for Apache Hive\lib\cacerts.pem
Ping from Windows
DSN Config
ODBC config
SSL Config
Table creation
Connect test
So it does work for non-TLS but when I enable TLS I get the below because TLS is not enabled on my HDP cluster , I will try in install sa self signed certificate and revert
Geoffrey
Created 04-21-2023 07:27 AM
@Shelton, wow apologies, now I´m reading, excellent test.
Could you do testing with TLS/SSL?
I still haven`t solved this.. 😞
Thank you for your support.