Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

SAP with Hive - Cloudera ODBC Driver - DSN Error 1100

avatar
Contributor

Hi Community Team,

 

I have a Private Cloud Base Platform 7.1.7.SP1 with hive 3.1. I need to connect my SAP server (Windows server) to hive. I installed Cloudera ODBC driver 2.6.13 and when I configured the DSN, shows me an error

 

"ERROR 1100 SSL certificate verification failed because the certificate is missing or incorrect.

 

- I have the AUTO TLS/SSL installed in the cluster. Hive has enabled TLS/SSL.

My Questions: 

- How I generate a certificate .jks to this server that is not part of the cluster CDP.

- What other steps I do to resolve this.

 

Thank for your support.

 

3 REPLIES 3

avatar
Contributor

Another Question: other option can be Install jdbc?

avatar
Master Mentor

@vciampa 

I tried to recreate your scenarion using HDP and ODBC

ODBC screens

I created a hive database and table and used a non ssl connection as shown below as my HDP is not Secured, though the ODBS delivers a certificate in C:\Program Files\Cloudera ODBC Driver for Apache Hive\lib\cacerts.pem

Ping from Windows 

Shelton_3-1680132850585.png

DSN Config

Shelton_6-1680133022851.png

 

ODBC config

Shelton_0-1680132690118.png

SSL Config

Shelton_5-1680132981121.png

 

 

 

 

Shelton_1-1680132763354.png

Table creation

Shelton_4-1680132901988.png

 

Connect test

Shelton_7-1680133073194.png

So it does work for non-TLS but when I enable TLS I get  the below because TLS is not enabled on my HDP cluster , I will try in install sa self signed certificate and revert

Shelton_8-1680133569615.png

 




Geoffrey

avatar
Contributor

@Shelton, wow apologies, now I´m reading, excellent test.

Could you do testing  with TLS/SSL?

I still haven`t solved this..  😞

 

Thank you for your support.