Support Questions

Find answers, ask questions, and share your expertise

SSH is not working for cloudbreak node(google Cloud)

Rising Star

I am using following document for cloud break deployment.

I created VM using Cloudbreak deployer image by executing the following command
gcloud compute images create cloudbreak-deployer-220-2017-12-19 --source-uri gs://sequenceiqimage/cloudbreak-deployer-220-2017-12-19.tar.gz
after successful creation i am try to do ssh on VM using puyty. but we get following error.

Error - Server refused our key.
Disconnected: No supported authentication methods available (server sent: publickey, gssapi-keyex, gssapi-with-mic)

Firewall rules for port 22 - OK
Private Public Key - OK


Expert Contributor

Hi @Bhupesh Khanna,

This error is shown when you are trying to login with an unavailable method. In this case it seems to me that you tried to login with password instead of key. Did you set the private key correctly in putty->connection/ssh/auth/private key?

Rising Star

@mmolnar ,Yes i correctly generate the private & public key using puttygen, also place correctly in putty, even i checked with other team members as well, and all having the same issue.

Expert Contributor
@Bhupesh Khanna

could you try with putty command line like:

putty.exe -i path_to_your_private_key.ppk cloudbreak@gcp_host_ip

or with cygwin to see if it is working.

I just tested with the same image as you mentioned above and I managed to connect with ssh.

Rising Star


same error

attached the screen shot

Expert Contributor

Hi @Bhupesh Khanna,

It seems we might have to upgrade our images with GCP Linux guest environment.

Until then you can connect with ssh from GCP console and add your key manually or from still the GCP console ssh install the guest environment: Install Guest Environment In-Place If you choose the latter please be aware that your ssh key should have cloudbreak as comment.

Or as another option you can add ssh keys as a metadata: Managing SSH keys in Metadata