Support Questions
Find answers, ask questions, and share your expertise

Schema registry plugin can't add/enable in ranger service

Schema registry plugin can't add/enable in ranger service

Explorer

Hello,

For pre-defined access policy controls access to one or more Schema Registry entities I need to add or enable the schema_registry ranger plugin. But I didn't configure how to enable or add in Service Manager for cm_schema_registy Policy List.

Here is the link to Cloudera documentation for schema registry in ranger service.

Schema registry security add-in ranger 

 

for example:

As the documentation, ranger manage service seems like,

 

Screenshot-2021-01-05-at-11-51-09-AM

 

But in my ranger service manager, didn’t see the cm_schema_registry policy.

 

issue-screen-sort

 

So, my question is how to enable or add or user control schema registry from ranger service?

 

 

 

 

 

 

 



 

 
 
 
 
 
2 REPLIES 2
Highlighted

Re: Schema registry plugin can't add/enable in ranger service

New Contributor

I have the same problem.

I believe there is a problem in the creation of the schemaregistry user, and the service.

Highlighted

Re: Schema registry plugin can't add/enable in ranger service

Cloudera Employee

Hi @sujonict07,

 

The process for creating the service along with it user should be automatic.

 

Have you tried unchecking the *Ranger Service* checkbox in Schema Registry? 

 

Also, have you tried to run the Setup Ranger Plugin Service in Ranger actions?