Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Services fail to start/gets stuck on HDP 3.0 sandbox

Solved Go to solution

Services fail to start/gets stuck on HDP 3.0 sandbox

New Contributor

HI,

 

Since I am a novice in the Hadoop ecosystem and I have been trying to use the sandbox for HDP 3.0.1 in the past few days, the sandbox is behaving very strangely. In the beginning it used to work fine with all the services been started etc. just within a few minutes. However lately, the services most of the time fail to start or gets stuck at 55% or so for over an hour or even longer sometimes and still doesn't start. I have tried to uninstall and install again a couple of times but it doesn't help.

Could you please explain why this might be happening and how to correct that?

 

 

2.PNG

 

3.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Services fail to start/gets stuck on HDP 3.0 sandbox

Super Mentor

@tyadav 

HDP Sandbox is a learning setup which has a single node cluster with lots of services deployed to it.

So usually when you say "Start All Services" then it will attempt to start all the services that are not put into maintenance ... Which will create much load on the VM.

 

So ideally it will be best to just STOP the services that you are currently not using and then put them in Maintenance Mode. Then try to start the required services.

 

The Just start the services that you actually need for testing that way the load on the Sandbox host will be much less and you will find that operations will be executing much faster and you will also see some free memory on the sandbox host.

3 REPLIES 3

Re: Services fail to start/gets stuck on HDP 3.0 sandbox

Super Mentor

@tyadav 

HDP Sandbox is a learning setup which has a single node cluster with lots of services deployed to it.

So usually when you say "Start All Services" then it will attempt to start all the services that are not put into maintenance ... Which will create much load on the VM.

 

So ideally it will be best to just STOP the services that you are currently not using and then put them in Maintenance Mode. Then try to start the required services.

 

The Just start the services that you actually need for testing that way the load on the Sandbox host will be much less and you will find that operations will be executing much faster and you will also see some free memory on the sandbox host.

Re: Services fail to start/gets stuck on HDP 3.0 sandbox

New Contributor

@jsensharma Makes sense. Thanks.

 

However when individually starting the services, some of them still fail like Hive Metastore, Zepplin for example. Is it also because of the lack of memory? Since let's say I need the following services to run at once, HBase, Hive, MapReduce, HDFS, dataAnalytics and Zepplin.

Re: Services fail to start/gets stuck on HDP 3.0 sandbox

Super Mentor

@tyadav 

Also it will be great to start monitoring the free memory of the Sandbox host where all the components are running so that we will get better idea why the services are starting slow and taking almost 25 minutes time to start/fail to successfully start.

If you still find any failure in starting the selected services then please share the logs of those individual service components which are failing to start and also the "free -m" command output during the startup operation.

.

.

If your question is answered then, Please make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Don't have an account?
Coming from Hortonworks? Activate your account here