Support Questions

Find answers, ask questions, and share your expertise

Slider Client Install

Explorer

I'm about to install service in each node and I get this error while installing Slider Client in two nodes:

resource_management.core.exceptions.Fail: Applying File['/usr/hdp/current/slider-client/lib/slider.tar.gz'] failed, parent directory /usr/hdp/current/slider-client/lib doesn't exit
6 REPLIES 6

@Maryem Mary,

Can you try installing it manually using the REST API

curl -k -u {username}:{password} -H "X-Requested-By:ambari" -i -X PUT -d '{"HostRoles": {"state": "INSTALLED"}}' http://{ambari-host}:{ambari-port}/api/v1/clusters/{clustername}/hosts/{hostname}/host_components/SL...

Replace username , password , ambari-host , ambari-port, clustername , hostname values with your values.

Thanks,

Aditya

Explorer

it doesn't work for me

@Maryem Mary,

Can you paste the error that you get while running the above command.

Explorer

this is what i tried:

curl -k -u root:****** -H "X-Requested-By:ambari" -i -X PUT -d '{"HostRoles": {"state": "INSTALLED"}}' http://10.23.**.**:8080/api/v1/clusters/ensias/hosts/masternode.ensias/host_components/slider

Explorer

My Internet connection uses a proxy server how can I use the above command with proxy address ??

this is what i got:

HTTP/1.1 503 Service Unavailable
Server: squid/3.3.8
Mime-Version: 1.0
Date: Tue, 21 Nov 2017 10:20:20 GMT
Content-Type: text/html
Content-Length: 3604
X-Squid-Error: ERR_CONNECT_FAIL 110
Vary: Accept-Language
Content-Language: en
X-Cache: MISS from cacheP1
X-Cache-Lookup: MISS from cacheP1:3128
X-Cache: MISS from cache
X-Cache-Lookup: MISS from cache:3128
Via: 1.1 cacheP1 (squid/3.3.8), 1.1 cache (squid/3.5.20)
Connection: keep-alive

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html><head>
<meta http-equiv="Content-Type" CONTENT="text/html; charset=utf-8">
<title>ERROR: The requested URL could not be retrieved</title>

....

@Maryem Mary,

503 means that your ambari server is not responding or unavailable. Please make sure ambari server is running before hitting the API

Also in the url slider should be in caps

curl -k -u root:****** -H "X-Requested-By:ambari" -i -X PUT -d '{"HostRoles": {"state": "INSTALLED"}}' http://10.23.**.**:8080/api/v1/clusters/ensias/hosts/masternode.ensias/host_components/SLIDER

Just to check if ambari is working fine or not, you can another sample url

curl -k -u root:****** -H "X-Requested-By:ambari" http://10.23.**.**:8080/api/v1/hosts

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.