Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Solr UI shows wrong results when searching over sharded collections

Solved Go to solution
Highlighted

Solr UI shows wrong results when searching over sharded collections

New Contributor

Solr Search on sharded collections can not build Text facets correctly and outputs just 10 facets with the wrong results . As a proof of that i have created two exact copies of the same collection one with a single shard and one with three shards . As you can see from the screenshots a facet on the same field returns wrong results when performed on the sharded collection . 

I'm currently using Hue 3.9 on CDH 5.5.1

Any help would be appreciated

 

shardedCollectionScreenshot:https://drive.google.com/open?id=0B9kwpO07MNRNbXUxUGdJRzltTGc

singleCollectionScreenshot:https://drive.google.com/open?id=0B9kwpO07MNRNdnQ0R1FTc3NxdDQ

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Solr UI shows wrong results when searching over sharded collections

Super Collaborator
We have recently discovered an issue with the way hue sends facet requests to solr, and this has been identified as a bug. A future release of hue will change the way distributed faceting is called.

-pd

Re: Solr UI shows wrong results when searching over sharded collections

3 REPLIES 3

Re: Solr UI shows wrong results when searching over sharded collections

Super Collaborator
We have recently discovered an issue with the way hue sends facet requests to solr, and this has been identified as a bug. A future release of hue will change the way distributed faceting is called.

-pd

Re: Solr UI shows wrong results when searching over sharded collections

Re: Solr UI shows wrong results when searching over sharded collections

Explorer
The above link shows the issue as still open with Unresolved status. Is this bug resolved?

I am using Cloudera 5.9, Hue 3.10 & Solr 4.10.3. I am also facing the same issue.

Please let me know how to resolve this.