Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 12-06-2024 05:29 AM - edited 12-06-2024 06:25 AM
Hi all,
When running a Sqoop import , the job gets stuck at INFO mapreduce.Job: map 0% reduce 0%, and the process does not progress further. Additionally, the following error message appears in the logs:
INFO conf.Configuration: resource-types.xml not found.
INFO resource.ResourceUtils: Unable to find 'resource-types.xml'.
Despite this error, there are still plenty of available resources in the cluster, so resource allocation should not be the issue.
Created 12-08-2024 03:45 AM
any ideas please !
Created 12-11-2024 01:20 AM
@helk Welcome to our community! To help you get the best possible answer, I have tagged our Sqoop experts @M_Rahi @JoseManuel @Saurabhatiyal who may be able to assist you further.
Please feel free to provide any additional information or details about your query. We hope that you will find a satisfactory solution to your question.
Regards,
Vidya Sargur,Created 12-11-2024 06:33 AM
Hello,
These are NOT ERRORS:
INFO conf.Configuration: resource-types.xml not found.
INFO resource.ResourceUtils: Unable to find 'resource-types.xml'.As for this:
INFO mapreduce.Job: map 0% reduce 0%How many mappers were specified for the IMPORT?
Try locating the running containers in YARN and take a few JSTACKs to find out if the mapper is stuck waiting from your source database, if so make sure there are no firewall/network rules preventing the flow of data.
Are you able to execute SQOOP EVAL on the source DB?
If so, try using options:
-jt local
-m 1
--verboseIf the job completes, that would confirm a communication issue from your NodeManagers to the source DB