Support Questions
Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Sqoop Import from Oracle with Wallet

New Contributor


We are facing errors while trying to import data from Oracle configured with walletsFollowing is the error while executing the sqoop command

sqoop import --libjars /usr/local/sqoop/lib/oraclepki.jar --connect jdbc:oracle:thin:@testssl --username neon_main --password bullet --table APP_INSTANCE --verbose

Here , testssl is the wallet name configured in the listerner.ora.

The error thrown is

17/06/30 12:38:01 DEBUG manager.DefaultManagerFactory: Trying with scheme: jdbc:oracle:thin

17/06/30 12:38:01 DEBUG manager.OracleManager$ConnCache: Instantiated new connection cache.

17/06/30 12:38:01 INFO manager.SqlManager: Using default fetchSize of 1000

17/06/30 12:38:01 DEBUG sqoop.ConnFactory: Instantiated ConnManager org.apache.sqoop.manager.OracleManager@1623b78d

17/06/30 12:38:01 INFO tool.CodeGenTool: Beginning code generation

17/06/30 12:38:01 DEBUG manager.OracleManager: Using column names query: SELECT t.* FROM APP_INSTANCE t WHERE 1=0

17/06/30 12:38:01 DEBUG manager.SqlManager: Execute getColumnInfoRawQuery : SELECT t.* FROM APP_INSTANCE t WHERE 1=0

17/06/30 12:38:01 DEBUG manager.OracleManager: Creating a new connection for jdbc:oracle:thin:@testssl, using username: neon_main

17/06/30 12:38:01 DEBUG manager.OracleManager: No connection paramenters specified. Using regular API for making connection.

17/06/30 12:38:02 ERROR manager.SqlManager: Error executing statement: java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish the connection

at oracle.jdbc.driver.T4CConnection.logon(

at oracle.jdbc.driver.PhysicalConnection.<init>( at oracle.jdbc.driver.T4CConnection.<init>(

at oracle.jdbc.driver.T4CDriverExtension.getConnection(

at oracle.jdbc.driver.OracleDriver.connect(

at java.sql.DriverManager.getConnection(

at java.sql.DriverManager.getConnection(

at org.apache.sqoop.manager.OracleManager.makeConnection(

at org.apache.sqoop.manager.GenericJdbcManager.getConnection(

at org.apache.sqoop.manager.SqlManager.execute(

at org.apache.sqoop.manager.SqlManager.execute(

at org.apache.sqoop.manager.SqlManager.getColumnInfoForRawQuery(

at org.apache.sqoop.manager.SqlManager.getColumnTypesForRawQuery(

at org.apache.sqoop.manager.SqlManager.getColumnTypes(

at org.apache.sqoop.manager.ConnManager.getColumnTypes(

at org.apache.sqoop.orm.ClassWriter.getColumnTypes(

at org.apache.sqoop.orm.ClassWriter.generate(

at org.apache.sqoop.tool.CodeGenTool.generateORM(

at org.apache.sqoop.tool.ImportTool.importTable(




at org.apache.sqoop.Sqoop.runSqoop(

at org.apache.sqoop.Sqoop.runTool(

at org.apache.sqoop.Sqoop.runTool(

at org.apache.sqoop.Sqoop.main(

Caused by: The Network Adapter could not establish the connection

at at at at at oracle.jdbc.driver.T4CConnection.connect(

at oracle.jdbc.driver.T4CConnection.logon( ... 25 more

Caused by: The method specified in wallet_location is not supported. Location: /home/hadoop/app/Wallets/client_wallet




at ... 30 more

Steps followed to cofigure the SSL with Oracle wallet is described below.

.We have configured SSL in Oracle using the instructions in the following link(have followed the same instructions for RHEL)

1) Have created wallets for server & client.

2) Exchanged the wallets between the server and client

3) Able to successfully connect to the oracle using SSL through JDBC thin client

The sqlnet.ora content is as follows


The tnsnames.ora content is as follows


The listener.ora content is as follows


I am able to sucessfully connect to the Database using JDBC client.The content of the java program and the files associated are attached.Note:Have truncated the ip before attaching the file


Any help would be much appreciated.


New Contributor

Is it working for you or still no luck ? I am also trying Sqoop with ssl enabled oracle db through oracle wallet but getting the same error? 


Can you please provide me the steps to configure if it is working for you ?



New Contributor

Still Any One able to solve this issue?