Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Sqoop import failed

I tried to run Sqoop import from oracle db to hdp hive, it has thrown an error below.

18/02/12 07:48:11 INFO mapreduce.Job: Task Id : attempt_1510351993144_42440_m_000000_0, Status : FAILED Error: SQLException in nextKeyValue at org.apache.sqoop.mapreduce.db.DBRecordReader.nextKeyValue( at org.apache.hadoop.mapred.MapTask$NewTrackingRecordReader.nextKeyValue( at org.apache.hadoop.mapreduce.task.MapContextImpl.nextKeyValue( at$Context.nextKeyValue( at at at org.apache.hadoop.mapred.MapTask.runNewMapper( at at org.apache.hadoop.mapred.YarnChild$ at Method) at at at org.apache.hadoop.mapred.YarnChild.main(

Caused by: java.sql.SQLRecoverableException: No more data to read from socket at oracle.jdbc.driver.T4CMAREngineStream.unmarshalUB1( at oracle.jdbc.driver.DynamicByteArray.unmarshalCLR( at oracle.jdbc.driver.T4CMarshaller$BasicMarshaller.unmarshalBytes( at oracle.jdbc.driver.T4CMarshaller$BasicMarshaller.unmarshalOneRow( at oracle.jdbc.driver.T4CCharAccessor.unmarshalOneRow( at oracle.jdbc.driver.T4CTTIrxd.unmarshal( at oracle.jdbc.driver.T4CTTIrxd.unmarshal( at oracle.jdbc.driver.T4C8Oall.readRXD( at oracle.jdbc.driver.T4CTTIfun.receive( at oracle.jdbc.driver.T4CTTIfun.doRPC( at oracle.jdbc.driver.T4C8Oall.doOALL( at oracle.jdbc.driver.T4CPreparedStatement.doOall8( at oracle.jdbc.driver.T4CPreparedStatement.fetch( at oracle.jdbc.driver.OracleStatement.fetchMoreRows( at oracle.jdbc.driver.InsensitiveScrollableResultSet.fetchMoreRows( at oracle.jdbc.driver.InsensitiveScrollableResultSet.absoluteInternal( at at org.apache.sqoop.mapreduce.db.DBRecordReader.nextKeyValue(


Hey @Scott Shaw, Thanks for the update. Before post this issue I have already gone through the link which you have provided and its says's about.

FAILED Error: SQLException in nextKeyValue at and Causedby: java.sql.SQLException:Value'0000-00-00' can not be represented as java.sql.Date

But mine is about

FAILED Error: SQLException in nextKeyValue at and Caused by: java.sql.SQLRecoverableException: No more data to read from socket

Got this below error due to hiveserver2 went down. After Hiveserver2 was up and running the sqoop command worked.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.