Support Questions
Find answers, ask questions, and share your expertise

Step by step setup for Sandbox Needed

New Contributor

I am a beginner and following the Learning the Ropes tutorial and am unable to connect to the welcome screen. I have spent a few days trying different hosts file modifications and different browser address and none seem to work. I have also tried all these on a PC and Mac trying both VMware and VirtualBox. I have stuck with VirtualBox because it seem like the one people are most using in the forum questions. Can anyone please provide an actual step by step?

Things I have tried:

host file - localhost vs vs 192.168.XX.XX localhost

browser ips: vs localhost:8888 vs 192.168.XX.XX:8888

Firewall is NOT enabled

Also there are three choices when I start the VirtualBox

CentOs Linux (4.12.4-1.elrepo.x86_64) 7 (Core) - this generates a blank screen

CentOS Linux (3.10.0-514.26.2.el7.x86_64) 7 (Core) - this generates a blank screen

CentOS Linux (0-rescue-6f5d5e9d826b4471ad0elf7a92e697dd) 7 (Core) - this works and brings up the screen seen in the tutorial

Can someone explain this? Sorry I am a true beginner.


Hi @John Koop

On your local laptop, you can use a text editor add an entry to your hosts file (/etc/hosts if you are using a *nix or Mac machine) that looks like the following: sandbox

This allows your local laptop/PC to resolve "" in a browser to the IP address for your local host of

When you import the appliance to VirtualBox, you can start the VM and as you have already noted, boot into the third option for Linux OS's to start the Hortonworks Sandbox Software. When the software boots, you should see a screen that advises you to go to the start page of or

This start page contains some introduction material, as well as links to other areas like Ambari (

You should be able to follow the tutorial once you are booted into the corrected OS (third one), and able to bring the screens in a browser.

New Contributor

Thanks for the quick response, but I am still having issues. Here are screenshots.

I launch the Hortonwork's Sandbox Software and get 1.jpg

My hosts file is 2.jpg

Using both or in Chrome i get 3.jpg and 4.jpg.

Any ideas?


@John Koop

I have exactly the same sandbox , for the network I used Bridged Adapter

During boot you will see the IP allocated to the sandox take note

You will need this to get the correct IP address assigned to the sandbox in the /etc/hosts.

On the first screenshot press ALT+F5 to get the login then I think root/hadoop

Use that IP to update your /etc/host Its advisable to leave the first 2 default lines localhost localhost.localdomain localhost4 localhost4.localdomain4 
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 
IP_from_above sandbox 

Then use this new hostname FQDN or short name eg:


Hope that helps


New Contributor

i've the same problem.. (instead of port 8888) works on my part


i've the same issues.. but if you go to port 8080 (instead of 8888) you should go directly to the ambari login page

not that, that solves the problem, but it a temporarly workaround


@John Koop

Update to my earlier posting

Once on the linux prompt now you need to ssh into docker container, not the VM. Do this: #

 ssh -p2222 root@ 

password hadoop you will be requested to change the root password do that

There after you can now reset the ambari admin password

# ambari-admin-password-reset 

After the successful change of the ambari admin password.

Ambari will restart and now you can log on using port 8080 and user/password admin/xxxx frm above

Hope that helps

Super Mentor

@John Koop

From your attached screenshot looks like 8888 port is not accessible outside sandbox which should not happen. So we can do the following testing to check few things:

1. Login to Sandbox and check if the port 8888 is actually opened.

# ssh root@  -p 2222
# netstat -tnlpa | grep 8888


2. Also please check the default "/etc/hosts" inside the sandbox which usually looks like something as following if you have not modified it. "below is output from my HDP 2.6" sandbox.

[root@sandbox ~]# cat /etc/hosts    localhost
::1    localhost ip6-localhost ip6-loopback
fe00::0    ip6-localnet
ff00::0    ip6-mcastprefix
ff02::1    ip6-allnodes
ff02::2    ip6-allrouters sandbox

3. If we see that the port is opened then we will need to check if by default Firewall is not causing any issue:

# service iptables status
# service iptables stop


4. Next we will check if the Port forwarding is correct and the 8888 port is unblocked and allows port forwarding. Please see the below link for port forwarding configuration and validation:

5. Still if you face any issue then try restarting the HDP Sandbox and then try again.

6. If the issue still occurs then try re importing the HDP sandbox images and then try again.


Reference: For step by step Sandbox installation the following link is useful:


@John Koop

Did you read my update ?


Hi @John Koop

I saw the screenshots, screenshot #1 looks good. Once you are there, can you access Ambari on ? If so, you can start the tutorials, the welcome page on port 8888 is not really mandatory.

New Contributor

@Geoffrey Shelton Okot

I did thank you. However, I am still unsuccessful. See

6.jpg where I attempted your answer.

5.jpg where I attempted @Willem Bressers

7.jpg where I attemped @Jay SenSharma and your answers