Support Questions
Find answers, ask questions, and share your expertise

Supported versions of Azul Zulu

New Contributor

Hello,

I'm trying to figure out whether Azul Zulu versions 8.58.0.13, 11.52.13 or 17.30.15 are supported by Cloudera and compatible with CDP Private Cloud 7.1.7, CM 7.4.4 and CDSW 1.9.0 ?

 

Thanks and regards,

Olek

1 ACCEPTED SOLUTION

Super Collaborator

Hello @AWlodarczyk 

 

Thanks for using Cloudera Community. The Link [1] covers the Minimum Requirement for both rows in their respective families. In other words, Azul JDK8 Family (8.56.0.21 & Above) & Azul JDK11 Family (11.50.19 & Above). They don't apply for Azul JDK13, Azul JDK15 & Azul JDK17 Family [2] for now. In [3], Your Team shall observe the JDK & the respective JDK Family Version being referred. 

 

Let us know if the above Post answer your queries. 

 

Regards, Smarak

 

[1] https://docs.cloudera.com/cdp-private-cloud-upgrade/latest/release-guide/topics/cdpdc-java-requireme...

[2] https://www.azul.com/downloads/?package=jdk

[3] https://supportmatrix.cloudera.com/

View solution in original post

6 REPLIES 6

Hi @AWlodarczyk 

You can figure out the answer to your question by consulting the documentation for CDP Private Cloud, starting out at this page:

Java Requirements

…and scrolling downwards until you find the JDK you are interested in.

 

 

Bill Brooks, Community Moderator
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

Hi Bill,

 

Frankly, it was exactly this page: Java Requirements | CDP Private Cloud (cloudera.com) that provoked my question. If read literally, it means only versions >= 8.56.0.21 and version 11.50.19 are supported, but 11.52.13 is not (since it is not mentioned there). If we assume "Minimum required version" applies also to the second row of the table (version 11.50.19), it could be read as: version 17.30.15 is also supported (because 17.30.15 is >= 11.50.19).

Since my preference is like: 17.30.15 > 11.52.13 > 8.58.0.13 I would like to know which exactly version of these 3 is actually compatible and supported by Cloudera.

 

Thanks in advance for your answer!

New Contributor

Hi @ask_bill_brooks 

Could you please confirm whether any of the following versions:

8.58.0.13

11.52.13

- 17.30.15

of Azul Zulu OpenJDK is officially compatible with CDP and supported by Cloudera?

@AWlodarczyk No, I can neither confirm nor deny that any or all of the three specific point releases of the Azul Zulu OpenJDK you've listed is officially compatible with CDP and supported by Cloudera. This thread will remain open and perhaps someone in Cloudera support will see it and reply here.

 

 

Bill Brooks, Community Moderator
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Super Collaborator

Hello @AWlodarczyk 

 

Thanks for using Cloudera Community. The Link [1] covers the Minimum Requirement for both rows in their respective families. In other words, Azul JDK8 Family (8.56.0.21 & Above) & Azul JDK11 Family (11.50.19 & Above). They don't apply for Azul JDK13, Azul JDK15 & Azul JDK17 Family [2] for now. In [3], Your Team shall observe the JDK & the respective JDK Family Version being referred. 

 

Let us know if the above Post answer your queries. 

 

Regards, Smarak

 

[1] https://docs.cloudera.com/cdp-private-cloud-upgrade/latest/release-guide/topics/cdpdc-java-requireme...

[2] https://www.azul.com/downloads/?package=jdk

[3] https://supportmatrix.cloudera.com/

New Contributor

Hello @smdas 

 

Thank you very much! It is exactly this confirmation which I needed. Thanks!

 

Best regards,

Olek

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.