Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Switching to local repo (artifactory) is causing the error: No package found for hadoop-${stack_version}-client(hadoop-(\d|-)+-client$)

avatar
Contributor

Due to changes in our networking and firewall requirements we had to switch from the hortonworks public repositories to the local repositories (artifactory).
After making this change we are seeing the following exception when we try to "Start All" (from Ambari) Which triggers the installation of the client packages and they are failing with the following exception.

Essentially similar error is thrown when we try to install any new package after this change.

OS: Ubuntu 16.04


No package found for hadoop-${stack_version}-client(hadoop-(\d|-)+-client$)
2019-05-29 15:47:30,684 - The repository with version 2.6.5.0-292 for this command has been marked as resolved. It will be used to report the version of the component which was installed

Command failed after 1 tries
1 ACCEPTED SOLUTION

avatar
Master Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
4 REPLIES 4

avatar
Contributor

Hi @Jay Kumar SenSharma and @subhash parise Looks like you are the SME's about the repository related issues.. Can you please advise on what I should do to fix this issue?

avatar

The above was originally posted in the Community Help Track. On Mon Jun 3 17:43 UTC 2019, a member of the HCC moderation staff moved it to the Security track. The Community Help Track is intended for questions about using the HCC site itself.

Bill Brooks, Community Moderator
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

avatar
Master Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Contributor

@Jay Kumar SenSharma
Thank you very much. That solved the issue.

And to answer your questions for completeness and for other members of the community..
Ambari Version = 2.6.2.2

Yes, we did install the components using the hortonworks public repo for ubunutu..

Because of the firewall requirements we had to create use our internal repo and hence chanted the repo in ambari server to point to the internal repo server.

After that we are seeing the error mentioned.