Support Questions

Find answers, ask questions, and share your expertise

There is no way to get ambari UI after installation

I installed ambari and setup it with help this man: https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.0/bk_ambari-installation/content/log_in_to_ap...

I user virtualbox on which installed centos7.

I installed ambari-server, after I started it. It started with message "Server started listening on 8080". But I can't get ambariUI at all. My inet address in ifconfig -a is "inet 10.0.2.15". So I try to ping 10.0.2.15:8080 and it messages that no such service or server. After I tried to connect via browser, it's the same. I can't get AmbariUI and I don't know how to fix it. It seems to be easy but something went wrong. After ambari installation and starting it I checked log file and everything is fine. So what's the problem can't got it.

Thank you.

1 ACCEPTED SOLUTION

Mentor

@David Manukian

Are you accessing the Ambari from your Virtual box host? If so make sure the VirtualBox IP entry is in your local host's file in C:\Windows\System32\drivers\etc assuming you are using windows.

In the below example my VirtualBox network setting is set to Bridged adapter so it picks my LAN network a class C

192.168.0.227  sandbox.hortonworks.com sandbox

So I can access my Ambari from my laptop using http://sandbox:8080

I think 10.0.2.15:8080 is only accessible if you are running firefox from the virtual box can you verify using curl

curl -u username:password -G http://ambari_server_ip:8080/api/v1/check

The desired output should be running that will confirm ambari is indeed accepting connections

View solution in original post

19 REPLIES 19

@David Manukian

Try to see if process if running or not

ps -ef | grep ambari-server

see whether port is lessoning

lsof -nalp | grep 8080

Then if everything is working as expected, the try with full qualified domain name like FQDN:8080

Hope this helps you.

[root@localhost /]# ps -ef | grep ambari-server

root 1009113210 Mar16 pts/000:00:00 tail -f -n 1000 ambari-server.out

root 1031213210 Mar16 pts/000:00:00 tail -f -n 1000 ambari-server.log

root 1032313210 Mar16 pts/000:00:00 tail -f -n 500 ambari-server.pid

root 1032713210 Mar16 pts/000:00:00 tail -f -n 500 ambari-server.out

root 1034513210 Mar16 pts/000:00:00 tail -f -n 1000 ambari-server.out

root 1034613210 Mar16 pts/000:00:00 tail -f -n 1000 ambari-server.log

root 12840 13 00:50 pts/000:00:51 /usr/jdk64/jdk1.8.0_112/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -XX:+CMSClassUnloadingEnabled -Dsun.zip.disableMemoryMapping=true -Xms512m -Xmx2048m -XX:MaxPermSize=128m -Djava.security.auth.login.config=/etc/ambari-server/conf/krb5JAASLogin.conf -Djava.security.krb5.conf=/etc/krb5.conf -Djavax.security.auth.useSubjectCredsOnly=false -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/share/java/mysql-connector-java.jar org.apache.ambari.server.controller.AmbariServer

root 1383913210 01:13 pts/000:00:00 grep --color=auto ambari-server

Thank you for your answer. It doesn't work with FQDN.

[root@localhost /]# hostname -f

localhost

[root@localhost /]# ping localhost:8080

ping: localhost:8080: Name or service not known

Hi @David Manukian

This seems to be a virtualbox network configuration issue. Check your port forwarding and add a rule for 8080.

I added it


screen-shot-2018-03-17-at-223434.png

Thank you for your answer. It doesn't help. As well as I can't even to ping it.

Mentor

@David Manukian

Are you accessing the Ambari from your Virtual box host? If so make sure the VirtualBox IP entry is in your local host's file in C:\Windows\System32\drivers\etc assuming you are using windows.

In the below example my VirtualBox network setting is set to Bridged adapter so it picks my LAN network a class C

192.168.0.227  sandbox.hortonworks.com sandbox

So I can access my Ambari from my laptop using http://sandbox:8080

I think 10.0.2.15:8080 is only accessible if you are running firefox from the virtual box can you verify using curl

curl -u username:password -G http://ambari_server_ip:8080/api/v1/check

The desired output should be running that will confirm ambari is indeed accepting connections

I can get connect to virtual host from local. My virtualhost ip address is 192.168.0.75 and when I make ping from local host it works but when I try to add port 8080 for checking ambari it doesn't work and the browser the same situation. I tried to rich via curl in virtualbox as you suggested and it works.

My networks is bridge-netowork and host-only as well. Neither bridge nor host-only doesn't allow me to make request from local machine

The problem was because of iptables. I turn off it and it works with NAT (port forwarding)

Mentor

@David Manukian

Check this HCC learning rope link it should help you with the port forwarding that's the problem you are encountering

Mentor

@David Manukian

Can you share your local hosts entry, make sure you commented out the below

#127.0.0.1       localhost
#::1             localhost

Please revert

Mentor

@David Manukian

My previous hosts file was from my windows laptop I am not conversant with Macbooks 🙂


MacOSFirewall setting

Go to System Preferences, Security & Privacy, Firewall, Firewall Options...

see attached screenshot

Your ambari UI should be accessible

http://192.168.0.75:8080 or http://ambari.training:8080


Port forwarding

Quite simple to do, Firstly you will need to enable the remote login service on your mac (System Preferences -> Sharing -> Remote Login). This starts your ssh server. Then run the following command in your OS X Terminal: The format is thus basically:

ssh -L local_addr:local_port:remote_addr:remote_port -N 127.0.0.1 

example

ssh -L 200.234.XXX.XXX:10000:10.211.55.5:80 -N 127.0.0.1 

You may need to accept the server fingerprint initially as well as type in your local password for ssh login. (You can also set up a local to local ssh public/private key to make it not prompt for a password, but that it a different exercise.)

My ssh works fine. The trouble in another. In virtualmachine curl works fine with port 8080, I really see it works. So, from local machine I make ping to virtualmachine and it works also but when I put port with host it doesnt work. I can't understand what's wrong it really makes me stupid lol. I even add hostonly network it means that no problem in communication localmachine to virtual but anyway with port it doesnt work.

Noway to connect to ambari from local browser, just noway.

Firewall and other gateway is off on my mac.

64676-screen-shot-2018-03-18-at-035100.png

it's via ssh in virtualbox. See that ambari works in virtualmachine but when I try to connect from local it doesn't see

Mentor

@David Manukian

That's the image I forgot to attach sorry


macos.jpg

It didn't help.