Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

Solved Go to solution

Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

Contributor

I am attempting to create a Falcon cluster entity using the Web UI.

**My Environment**

I have a functioning Oozie Server (have successfully run workflows from the command line, and I can access the Oozie Web UI without issue). I have a three-node cluster running in Docker. Both Falcon and Oozie are installed on node2.

**The Error**

845-error.png

Note: The way name resolution is set up, FQDNs are not required in my environment, or rather, "node2" is the FQDN equivalent.

**Troubleshooting So Far**

I have tried replacing node2 with the IP address. I get the same error:

846-error2.png

I have confirmed that I can access this URL via the Oozie Web UI. Just to be pedantic, I also performed a port scan to confirm that port 11000 was truly open on the server.

What could be causing this error? Are there additional troubleshooting steps I can take?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

Rising Star

Please refer to http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-... specifically the section about setting proxy user settings in oozie for falcon.

4. Add the following properties to custom oozie-site , your set up has it in custom core-site. Then restart oozie and you should be able to submit the cluster entity.

<property>
     <name>oozie.service.ProxyUserService.proxyuser.falcon.hosts</name>
     <value>*</value>
</property>
 
<property>
     <name>oozie.service.ProxyUserService.proxyuser.falcon.groups</name> 
     <value>*</value>
</property>

View solution in original post

6 REPLIES 6
Highlighted

Re: Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

Rising Star

Hi Jeden : When you see an error like this, it means that Falcon server is unable to contact oozie server. Can you please try "curl from the falcon server and let us know if it works.

You can get further information about the underlying exception if you look at falcon.application.log. Please share that exception as well, and we will be able to help you.

Highlighted

Re: Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

Contributor

Balu - here are the results of the cURL from the Falcon server -- it works fine:

847-curltest.png

As far as the log file goes, the error I'm getting back indicates failure because Falcon is not set up as a proxy user. Here's the pertinent snippet, I think:

848-log2.png

However, as I will show in my next post, I have set up both falcon and oozie proxyuser settings as * so I'm not sure why that would be an issue here.

Highlighted

Re: Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

Contributor

Here's part 2 of the answer, with the screenshot showing my current proxyuser settings for falcon and oozie:

849-proxyusersettings.png

I realize it's possible I've missed something...

Highlighted

Re: Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

Rising Star

Please refer to http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-... specifically the section about setting proxy user settings in oozie for falcon.

4. Add the following properties to custom oozie-site , your set up has it in custom core-site. Then restart oozie and you should be able to submit the cluster entity.

<property>
     <name>oozie.service.ProxyUserService.proxyuser.falcon.hosts</name>
     <value>*</value>
</property>
 
<property>
     <name>oozie.service.ProxyUserService.proxyuser.falcon.groups</name> 
     <value>*</value>
</property>

View solution in original post

Highlighted

Re: Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

Contributor

Ahhh, perfect. Thanks!

Highlighted

Re: Troubleshoot Falcon Web UI Cluster Creation - Invalid Workflow Server or Port Error

New Contributor

I am also facing the same problem i have tried the below

Disable proxy and connectting oozie from curl command it works fine . I am still getting the invalid oozie server or port .

.And my hivemetastore is not working .But i have ignored it can that be of any way a problem in submitting falcon entity

Don't have an account?
Coming from Hortonworks? Activate your account here