Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Try to connect nifi to PutMarkLogic processor

avatar
Explorer

Hello Cloudera folks,

Good Day! I'm having a issue when i tried to connect the nifi putMarkLogic processor marklogic db, when I checked the roles in marklogic end the rest-writer and rest-read are already checked also but still encounter the issue below.

from marklogic logs.
"GET /v1/internal/forestinfo?database=data-hub-STAGING HTTP/1.1" 404 0 - "okhttp/3.10.0"

from nifi popup error.

 

nifi_error.png

if you have any thoughts it's very helpful to us.

Thanks,

Vin 

1 REPLY 1

avatar
Master Mentor

@ajignacio 
The PutMarkLogic processor is not a component bundled and shipped with Apache NiFi, so I am not familiar with it.  You may want to raise your issue directly with those who developed this connector and include your Apache NiFi version specifics as well:
https://github.com/marklogic/nifi/issues

Please help our community grow. If you found any of the suggestions/solutions provided helped you with solving your issue or answering your question, please take a moment to login and click "Accept as Solution" on one or more of them that helped.

Thank you,
Matt