Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Trying to deploy Apache Metron on single node VM, but Ansible and maven dependency failures, please help I am stuck



I am trying to deploy Apache Metron on a single node VM, but after vagrant up, when I run vagrant provision, it gives me errors on maven dependencies and ansible failed to setup successfully.

I have installed all packages defined for Metron deployment, Ansible, Vagrant 1.9.6, Maven 3.3.9, Virtual Box 5.1.30 JDK 1.8 and Python 2.7.5

Also, when I run the command "mvn clean package", metron-config error pops up and it doesnt complete its installation, followed by metron-rest, metron-rest client


Super Collaborator

Hey @Gaurav Bapat, you need not run the mvn command every time. Just once should suffice. Also, if you have used the full-dev vagrant deployment, you need not have to do anything with Ambari UI (or the Step 3 screenshot) you have pasted.

So, let me paraphrase the steps for you so that you can give this a try once more, afresh. Let me know how it goes.

Assumption: Say your metron folder is located at: /user/gaurav/metron

Step 0 - Cleanup all existing deployments:

* Run the following commands:

cd /user/gaurav/metron/metron-deployment/vagrant/full-dev-platform
vagrant destroy -f

* The above destroy command would terminate and delete the existing running VM. You can also run 'VirtualBox' command to launch the application console, and can delete any other stray VMs that are not required.

Step 1 - Compile metron

* Run the following commands:

cd /user/gaurav/metron
mvn clean compile -DskipTests

* The above command will take about 10 mins or so to complete, and should end with a "SUCCESS" message

Step 2 - Bring up metron VM

* Run the following commands:

cd /user/gaurav/metron/metron-deployment/vagrant/full-dev-platform
vagrant up

* The above command will take about 45 mins to over an hour to complete. I would recommend that you disable auto-sleep of the system in case it is enabled.

At the end of the step 2 above, you should be able to see a message saying that the deployment completed successfully.

View solution in original post




SELinux is preventing /usr/bin/install from read access

Also there is TLS handshake error and connection refused error on my Hbase&Metron component