Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Trying to submit pig job with oozie and yarn

Trying to submit pig job with oozie and yarn

New Contributor

Just got the CDH5 build of Oozie setup and am trying to get it to connect to Hadoop. When I try to submit the following

 

oozie pig -file test.pig -oozie http://localhost:11000/oozie -config job.properties

I get

java.lang.RuntimeException: jobtracker is not specified in conf
        at org.apache.oozie.client.XOozieClient.validateHttpSubmitConf(XOozieClient.java:117)
        at org.apache.oozie.client.XOozieClient.submitScriptLanguage(XOozieClient.java:199)
        at org.apache.oozie.cli.OozieCLI.scriptLanguageCommand(OozieCLI.java:1693)
        at org.apache.oozie.cli.OozieCLI.processCommand(OozieCLI.java:551)
        at org.apache.oozie.cli.OozieCLI.run(OozieCLI.java:506)
        at org.apache.oozie.cli.OozieCLI.main(OozieCLI.java:192)
jobtracker is not specified in conf

 

I'm sure I am doing something dumb or missed a config but I can't figure out what.

 

I tried a jobTracker= directive in my properties but that didn't seem to work, and removing it didn't cause a different error, so I assume its not getting that far.

2 REPLIES 2

Re: Trying to submit pig job with oozie and yarn

New Contributor

So I went reading the code. I discovered that using

 

fs.defaultFS and mapreduce.jobtracker.address in my job.properties file seems to have solved the problem.

 

Perhaps it was earlier versions of Ooozie which used jobTracker and nameNode

Re: Trying to submit pig job with oozie and yarn

New Contributor

I just discovered this and it seems like I am having the same issue as you had. You said you started using fs.defaultFS and mapreduce.jobtracker.address in job.properties. Does this also mean that you switched out the variables in your workflow? Or was there somewhere else you did this?

 

I know you resolved this a while ago but Oozie has been giving me so many compatibility issues and this would really hel.