Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable To Login Via Default Login Credentials of Admin in Ambari

Solved Go to solution

Unable To Login Via Default Login Credentials of Admin in Ambari

Explorer

I installed hortonworks sandbox around two weeks ago on a cloud server of linode with a machine of 8GB RAM. I access this node of Linode via Putty. On that node, I'm using hadoop inside a docker that I installed on that system.

Everything is working fine. Also, I am able to login Ambari via the default login credentials like maria_dev, raj_ops, holger_govand amy_ds.

But I am unable to login via the default login credentials of admin. In the command line, I tried the following commands :

1. ambari-server restart  
2. ambari-admin-password-reset

But even after changing the password, it didn't workout for me.

Also I tried changing it from the backend and login :

1. # psql -U ambari -d ambari
2. Passwordfor user ambari: bigdata
3. ambari=> update ambari.users set user_password='538916f8943ec225d97a9a86a2c6ec0818c1cd400e09e03b660fdaaec4af29ddbb6f2b1033b81b00'where user_name='admin';
4. ambari=> \q# 
5. ambari-server restart

After the 5th step the password should be admin. But it is not the case. I was still unable to login. Also after the 5th step, i.e. after typing ambari-server restart and hitting enter, I was getting the following error :

Using python  /usr/bin/python                                                                                                                        
Restarting ambari-server                                                                                                                             
Traceback (most recent call last):                                                                                                                   
  File "/usr/sbin/ambari-server.py", line 36, in <module>                                                                                            
    from ambari_server.dbConfiguration import DATABASE_NAMES, LINUX_DBMS_KEYS_LIST                                                                   
  File "/usr/lib/python2.6/site-packages/ambari_server/dbConfiguration.py", line 28, in <module>                                                     
    from ambari_server.serverConfiguration import decrypt_password_for_alias, get_ambari_properties, get_is_secure, \                                
  File "/usr/lib/python2.6/site-packages/ambari_server/serverConfiguration.py", line 593, in <module>                                                
    configDefaults = ServerConfigDefaults()                                                                                                          
  File "/usr/lib/python2.6/site-packages/ambari_server/serverConfiguration.py", line 503, in __init__                                                
    super(ServerConfigDefaultsLinux, self).__init__()                                                                                                
  File "/usr/lib/python2.6/site-packages/ambari_server/serverConfiguration.py", line 363, in __init__                                                
    self.OUT_DIR = parse_log4j_file(get_conf_dir() + "/log4j.properties")['ambari.log.dir'].replace("//", "/")                                       
  File "/usr/lib/python2.6/site-packages/ambari_commons/os_utils.py", line 194, in parse_log4j_file                                                  
    with open(filename, "rb") as fp:                                                                                                                 
IOError: [Errno 2] No such file or directory: '/etc/ambari-server/conf/log4j.properties' 

I am getting the IOError. I'm unable to sort out the issue.

Can someone please help me to login via the login credentials of admin ?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Unable To Login Via Default Login Credentials of Admin in Ambari

Super Mentor

@Amogh Suman

I guess once the "log4j.properties" error is resolved then you should be able to start the Ambari Server properly.

Please follow the suggestion mentioned in the other HCC thread of yours to fix the missing "log4j.properties" issue and then restart ambari server.

https://community.hortonworks.com/questions/157756/ioerror-errno-2-no-such-file-or-directory-etcamba...

.

View solution in original post

4 REPLIES 4
Highlighted

Re: Unable To Login Via Default Login Credentials of Admin in Ambari

Super Mentor

@Amogh Suman

I guess once the "log4j.properties" error is resolved then you should be able to start the Ambari Server properly.

Please follow the suggestion mentioned in the other HCC thread of yours to fix the missing "log4j.properties" issue and then restart ambari server.

https://community.hortonworks.com/questions/157756/ioerror-errno-2-no-such-file-or-directory-etcamba...

.

View solution in original post

Highlighted

Re: Unable To Login Via Default Login Credentials of Admin in Ambari

Super Mentor

@Amogh Suman

As the current issue which is originally described in this HCC thread is resolved hence i will suggest you to please open a new HCC thread for the new issue.

ServiceHive check failed:Cannot open a hive connection with connect string jdbc:hive2://sandbox-hdp.hortonworks.com:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2;hive.server2.proxy.user=admin

Keeping different issues as part of different HCC threads helps is improving HCC community better and more useful.

.

As the issue is resolved, hence it will be also great if you can mark this HCC thread as Answered by clicking on the "Accept" Button on the correct answer. That way other HCC users can quickly find the solution when they encounter the same issue.


Highlighted

Re: Unable To Login Via Default Login Credentials of Admin in Ambari

Explorer

ok, sure. I'll do that. Thanks a ton. :) :)

Highlighted

Re: Unable To Login Via Default Login Credentials of Admin in Ambari

Explorer

Yes, I solved that issue. And I was able to login as admin as well. Thanks for helping me out. Now within the admin account, I'm facing one more problem : on clicking on Hive View I'm getting the following error :

Service Hive check failed: Cannot open a hive connection with connect string jdbc:hive2://sandbox-hdp.hortonworks.com:2181/;serviceDiscoveryMode=zooKeeper;zooKeeperNamespace=hiveserver2;hive.server2.proxy.user=admin

Can you please help me sort out this problem as well ?

Don't have an account?
Coming from Hortonworks? Activate your account here