Support Questions
Find answers, ask questions, and share your expertise

Unable install Infra and LogSearch Feeder with error: java.lang.IllegalArgumentException: Invalid rule: RULE

Highlighted

Unable install Infra and LogSearch Feeder with error: java.lang.IllegalArgumentException: Invalid rule: RULE

Explorer

I am working on a HDP 2.5 kerberized cluster and I am trying to install Infra and LogSearch. When I tried to do it from Ambari UI, it stays at "Install Pending" and it doesn't do anything else after that even if I click Re-install. Then I tried to install and start the components using the Rest API and I am seeing this error:

{ "status" : 400, "message" : "java.lang.IllegalArgumentException: Invalid rule: RULE:[2:$1@$0(rangerusersync@XXXX)s/.*/rangerusersync/" }

I see that it is missing a "]" right after the "@$0". So I checked the HDFS config to find the "hadoop.security.auth_to_local" property has the correct corresponding rule. So I am not quite sure where the discrepancy is. Can someone help me out with this?

TIA,

K

1 REPLY 1
Highlighted

Re: Unable install Infra and LogSearch Feeder with error: java.lang.IllegalArgumentException: Invalid rule: RULE

Guru

Hello @Kay Aries,

Can you please add all the auth_to_local rules as seen in Ambari to the question? That will help us to determine what is wrong with the rules.

Also when you run the REST API, it must have given some error in Ambari Server log. Please paste the relevant section from that log (/var/log/ambari-server/ambari-server.log).

Hope this helps !