Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable to add JAAS configuration for client error when running sqoop job in unsecured cluster

Solved Go to solution
Highlighted

Unable to add JAAS configuration for client error when running sqoop job in unsecured cluster

Contributor

While running the sqoop command I get the following error message

ERROR security.InMemoryJAASConfiguration: Unable to add JAAS configuration for client [KafkaClient] as it is missing param [atlas.jaas.KafkaClient.loginModuleName]. Skipping JAAS config for [KafkaClient] 

Any pointers are appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Unable to add JAAS configuration for client error when running sqoop job in unsecured cluster

@Shashank Chandhok

Can you post your "Advanced sqoop-atlas-application.properties" here?

View solution in original post

4 REPLIES 4
Highlighted

Re: Unable to add JAAS configuration for client error when running sqoop job in unsecured cluster

@Shashank Chandhok

Can you post your "Advanced sqoop-atlas-application.properties" here?

View solution in original post

Re: Unable to add JAAS configuration for client error when running sqoop job in unsecured cluster

Contributor

@Sandeep Nemuri Here are the properties from my cluster.

# Generated by Apache Ambari. Mon Jun 12 12:33:51 2017
     
atlas.authentication.method.kerberos=False
atlas.cluster.name=mycluster
atlas.jaas.KafkaClient.option.renewTicket=true. 
atlas.jaas.KafkaClient.option.useTicketCache=true
atlas.kafka.bootstrap.servers=lab1.hwx.com:6667
atlas.kafka.hook.group.id=atlas
atlas.kafka.zookeeper.connect=lab1.hwx.com:2181
atlas.kafka.zookeeper.connection.timeout.ms=30000
atlas.kafka.zookeeper.session.timeout.ms=60000
atlas.kafka.zookeeper.sync.time.ms=20
atlas.notification.create.topics=True
atlas.notification.replicas=1
atlas.notification.topics=ATLAS_HOOK,ATLAS_ENTITIES
atlas.rest.address=http://lab1.hwx.com:21000
Highlighted

Re: Unable to add JAAS configuration for client error when running sqoop job in unsecured cluster

@Shashank Chandhok

Looks like atlas is using jaas to connect to kafka, You'd need to remove this properties as the cluster is unsecured.

/var/lib/ambari-server/resources/scripts/configs.sh -u admin -p admin delete localhost <cluster> sqoop.atlas.application.properties atlas.jaas.KafkaClient.option.renewTicket 

/var/lib/ambari-server/resources/scripts/configs.sh -u admin -p admin delete localhost <cluster> sqoop.atlas.application.properties atlas.jaas.KafkaClient.option.useTicketCache 
Highlighted

Re: Unable to add JAAS configuration for client error when running sqoop job in unsecured cluster

Contributor

@Sandeep Nemuri Awesome. That worked. Thanks.

Don't have an account?
Coming from Hortonworks? Activate your account here