Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable to change Storm scheduler by adding 'storm.scheduler' setting into storm.yaml file.

Unable to change Storm scheduler by adding 'storm.scheduler' setting into storm.yaml file.

New Contributor

I tried modifying the 'storm.scheduler' setting in /etc/storm/conf/storm.yaml because I need the resource aware scheduler (http://storm.apache.org/releases/current/Resource_Aware_Scheduler_overview.html) so that I can dedicate cores for executors.

I have two nimbuses and one supervisor and three zookeeper. I made the changes to the storm yaml file on the nimbus and supervisor machines. After I restart all components I checked all the storm yaml files but they no longer have my changes. This setting cannot be found listed in the Ambari UI so I cannot use the UI to address the issue.

1 REPLY 1
Highlighted

Re: Unable to change Storm scheduler by adding 'storm.scheduler' setting into storm.yaml file.

Contributor

This is an Ambari "feature". Every time you restart the service Ambari overrides the configuration with the configuration defined in Ambari.

To enable RAS you should go to Storm / Configuration / Custom storm-site then click on "Add property ...".

Then you'll be able to add your desired RAS setting:

storm.scheduler: “org.apache.storm.scheduler.resource.ResourceAwareScheduler”

After setting the param you should restart all the Storm services.

Don't have an account?
Coming from Hortonworks? Activate your account here