Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable to install Solr on Ambari 2.6 . Facing the following error: Unable to locate package lucidworks-hdpsearch .

Solved Go to solution

Unable to install Solr on Ambari 2.6 . Facing the following error: Unable to locate package lucidworks-hdpsearch .

New Contributor

I tried sudo apt-get install lucidworks-hdpsearch. That also gives the same error. My OS is ubuntu 16.04 and I have ambari 2.6 installed.

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/SOLR/6.6.2/package/scripts/solr.py", line 139, in <module>
    Solr().execute()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 375, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/common-services/SOLR/6.6.2/package/scripts/solr.py", line 20, in install
    self.install_packages(env)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 821, in install_packages
    retry_count=agent_stack_retry_count)
  File "/usr/lib/ambari-agent/lib/resource_management/core/base.py", line 166, in __init__
    self.env.run()
  File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/ambari-agent/lib/resource_management/core/environment.py", line 124, in run_action
    provider_action()
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/__init__.py", line 53, in action_install
    self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos)
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/apt.py", line 75, in wrapper
    return function_to_decorate(self, name, *args[2:])
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/apt.py", line 376, in install_package
    self.checked_call_with_retries(cmd, sudo=True, env=INSTALL_CMD_ENV, logoutput=self.get_logoutput())
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/__init__.py", line 266, in checked_call_with_retries
    return self._call_with_retries(cmd, is_checked=True, **kwargs)
  File "/usr/lib/ambari-agent/lib/resource_management/core/providers/package/__init__.py", line 283, in _call_with_retries
    code, out = func(cmd, **kwargs)
  File "/usr/lib/ambari-agent/lib/resource_management/core/shell.py", line 72, in inner
    result = function(command, **kwargs)
  File "/usr/lib/ambari-agent/lib/resource_management/core/shell.py", line 102, in checked_call
    tries=tries, try_sleep=try_sleep, timeout_kill_strategy=timeout_kill_strategy)
  File "/usr/lib/ambari-agent/lib/resource_management/core/shell.py", line 150, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/ambari-agent/lib/resource_management/core/shell.py", line 303, in _call
    raise ExecutionFailed(err_msg, code, out, err)
resource_management.core.exceptions.ExecutionFailed: Execution of '/usr/bin/apt-get -q -o Dpkg::Options::=--force-confdef --allow-unauthenticated --assume-yes install lucidworks-hdpsearch' returned 100. Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package lucidworks-hdpsearch
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Unable to install Solr on Ambari 2.6 . Facing the following error: Unable to locate package lucidworks-hdpsearch .

Super Mentor

@Abhishek Rawat

I looked at the SupportMatrix for Ambari 2.6 and i can see that it does not Support Ubuntu 16. Same goes for HDP Search 3.0 (which is compatible with Ambari 2.6) does have Ubuntu 16 as Supported OS. So i guess package dependencies can not be resolved if they are not present.

https://supportmatrix.hortonworks.com/

In the above link please click on the Ambari 2.6 versions and then scroll down to see the supported HDP search version along with the tested and certified OS.



View solution in original post

3 REPLIES 3
Highlighted

Re: Unable to install Solr on Ambari 2.6 . Facing the following error: Unable to locate package lucidworks-hdpsearch .

Super Mentor

@Abhishek Rawat

I looked at the SupportMatrix for Ambari 2.6 and i can see that it does not Support Ubuntu 16. Same goes for HDP Search 3.0 (which is compatible with Ambari 2.6) does have Ubuntu 16 as Supported OS. So i guess package dependencies can not be resolved if they are not present.

https://supportmatrix.hortonworks.com/

In the above link please click on the Ambari 2.6 versions and then scroll down to see the supported HDP search version along with the tested and certified OS.



View solution in original post

Highlighted

Re: Unable to install Solr on Ambari 2.6 . Facing the following error: Unable to locate package lucidworks-hdpsearch .

Super Mentor

@Abhishek Rawat .
If you want to use Ubuntu 16 then please try Ambari 2.7 + HDP Search 4.0 combination

Highlighted

Re: Unable to install Solr on Ambari 2.6 . Facing the following error: Unable to locate package lucidworks-hdpsearch .

New Contributor

Thank you for letting me know about the support matrix as its really very helpful. I will prefer to install ubuntu 14.04 as I also need JanusGraph on Ambari which by this link https://github.com/JanusGraph/janusgraph-ambari is not compatible on Ambari 2.7.

Don't have an account?
Coming from Hortonworks? Activate your account here