Support Questions

Find answers, ask questions, and share your expertise

Unable to run Hadoop commands

Expert Contributor

In the gateway cluster, one of the node is having issues. I am just running this command "hadoop dfsadmin -report|awk 'FNR == 3 {print $3}'" to get the remaining size and I get the following error message :

[gw2.prod.dfw ~]$ hadoop dfsadmin -report|awk 'FNR == 3 {print $3}' the Exception in thread "main" java.lang.NoClassDefFoundError: ___31598 Caused by: java.lang.ClassNotFoundException: ___31598 at java.net.URLClassLoader$1.run(URLClassLoader.java:217) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:205) at java.lang.ClassLoader.loadClass(ClassLoader.java:323) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294) at java.lang.ClassLoader.loadClass(ClassLoader.java:268) Could not find the main class: ___31598. Program will exit.

the same command is running fine from the other node. This is Hadoop V1.

Please advise.

1 ACCEPTED SOLUTION

Expert Contributor

@mqureshiI figured out..This is space issue. I cleared lots of old log files and it is working fine now

View solution in original post

2 REPLIES 2

Super Guru

Can you please check your classpath? run "hadoop dfsadmin" just by itself. I think you should still run into same issue. Then you need check your classpath and compare with the nodes where this command runs successfully. Can you please try that and share with us what you see?

Expert Contributor

@mqureshiI figured out..This is space issue. I cleared lots of old log files and it is working fine now

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.