Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 12-22-2021 07:10 AM
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors t>
Dec 22 04:06:46 vhcccloudera01d cm-server[771896]: 04:06:46.929 [main] ERROR org.hibernate.engine.jdbc.spi.SqlExceptionHelper - ERROR: relation "cm_version">
I am trying to run cloudera manager but my ip:7180 shows "cant be reached "
can anyone please tell how to resolve this
Created 12-24-2021 10:10 PM
This could the possible solution, Please share the CM server logs
1) log into CM server host and take a backup file of /etc/default/cloudera-scm-server to a backup location
2) Open /etc/default/cloudera-scm-server file and add the following to the CMF_JAVA_OPTS:
-Dlog4j.configurationFile=file:/etc/cloudera-scm-server/log4j2.properties
With the above configuration, the file looks like this:
[...]
export CMF_JAVA_OPTS="[...existing...javaoptions] -Dlog4j.configurationFile=file:/etc/cloudera-scm-server/log4j2.properties"
[...]
3) Create the /etc/cloudera-scm-server/log4j2.properties file.
#chmod 644 /etc/cloudera-scm-server/log4j2.properties
4) We noticed some issues with the ODBC connector:
#ls -ltr /usr/share/java/mysql-connector-java.jar
*Not existing file
6) We copied the ODBC from a different environment. Cloudera Manager is able to start, but it is failing to connect to DB, We granted more connections in the db.properties file:
#vi /etc/cloudera-scm-server/db.properties and add the below line in this file:
> com.cloudera.cmf.orm.hibernate.c3p0.max_statements=0 <
7) After the restart, the CM server started successfully
Created 01-04-2022 08:07 AM
@Akku97 Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. Thanks
Regards,
Diana Torres,