Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Unable to seed access policy on NIFI-1.16.0 and User_logs are also not getting generated


HI Team,

System Env Details: I am trying setup NIFI on AWS
3 node cluster
NIFI version:  1.16.0

Primarily I tried to setup 1 node with single-user-provider on AWS with NIFI-1.16.0 and able to perform each and every action. It is working fine.

Then I tried to setup 3 node cluster on AWS,
What went well.
1. Configured zookeeper in and Statemanagement.xml and able to formulate a cluster and cluster coordinator setup is successful.
2. using
3. Successfully able to integrate with SAML and able to login as a Admin user.

What went wrong:

1. Except User-logs, all other logs are getting generated (app, request, bootstrap)
2. When I have logged in as an Initial Admin Identity, Ideally I  should be able to add users and policy to them. However, I am getting  insufficient permissions while performing any action. (add policy, delete used, edit user, logout etc...)

Any help would be highly appreciated. 

For my detailed set kindly visit my post:


Super Mentor


Assuming you have NiFi configured to run securely (HTTPS enabled) then the nifi-iser.log should be generated.  I'd suggest inspecting the logback.xml to make sure there are no mistakes in the appender or loggers setup for the nifi-users.log.





Thank you for pointing out logback.xml, now am able to generate the users.log.