Support Questions
Find answers, ask questions, and share your expertise

Unable to start Master node services (ambari version 2.5)

Explorer
 raise Fail("Applying %s failed, parent directory %s doesn't exist" % (self.resource, dirname))
resource_management.core.exceptions.Fail: Applying File['/var/lib/ambari-agent/tmp/changeUid.sh'] failed, parent directory /var/lib/ambari-agent/tmp doesn't exist
Error: Error: Unable to run the custom hook script ['/usr/bin/python', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py', 'ANY', '/var/lib/ambari-agent/data/command-11717.json', '/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY', '/var/lib/ambari-agent/data/structured-out-11717.json', 'INFO', '/var/lib/ambari-agent/tmp', 'PROTOCOL_TLSv1']

Ambari version is 2.5

This issue is appearing on master node. All the services on master node is down.

Initially one of the data node was not able to make connection with master node. It seems that firewalld was not disable. we install the service and disabled it. and restarted ambari. After restarting ambari all the services on master node went down with above error. As this is master node so we wouldn't able to re-set ambari or reinstall it.

1 ACCEPTED SOLUTION

Explorer

Is that ambari-agent service still running? Or try to restart it.

[root@hdptest ~]# /etc/init.d/ambari-agent status
Found ambari-agent PID: 63290
ambari-agent running.
Agent PID at: /run/ambari-agent/ambari-agent.pid
Agent out at: /var/log/ambari-agent/ambari-agent.out
Agent log at: /var/log/ambari-agent/ambari-agent.log

View solution in original post

4 REPLIES 4

Explorer

Is that ambari-agent service still running? Or try to restart it.

[root@hdptest ~]# /etc/init.d/ambari-agent status
Found ambari-agent PID: 63290
ambari-agent running.
Agent PID at: /run/ambari-agent/ambari-agent.pid
Agent out at: /var/log/ambari-agent/ambari-agent.out
Agent log at: /var/log/ambari-agent/ambari-agent.log

New Contributor

Thanks Mark. Stopping and Starting agent (on masternode) resolved the problem

Mentor

@Fahad Sarwar

Can you attach the ambari-server log.

New Contributor

Thanks for responding Geoffery. Above solution provided by Mark resolved the issue./

; ;