Support Questions
Find answers, ask questions, and share your expertise

Unable to stop and start services via Ambari web UI.

Explorer

After a few months, my cluster is working properly. However, yesterday I've noticed that one of the services went down. I've tried to restart the service but it won't start. The action stuck in the background UI window seen in the image. I've tried to restart some services. However, the same issue encountered with the other service. I am thinking that there is something with Ambari UI sending the command to the cluster. Any suggestions would be helpful for me. Thank you

I've already restarted the ambari-server and ambari-agent. H
Ambari - BDO 2020-04-30 20-40-38.png

1 ACCEPTED SOLUTION

Accepted Solutions

Explorer

Hi @lwang .

Thank you for the quick response. I've solved the problem already. I found out that there are hung requests in the Ambari DB specifically on host_role_command which in charge of the Ambari Web UI operation. I remove those hung requests and resolved the problem. My cluster is now running smoothly. Thanks

View solution in original post

3 REPLIES 3

Super Collaborator

Hi @TR7_BRYLE ,

 

Thanks for reaching out to Cloudera community.

 

Could you please share the Ambari server log ambari-server.log and see if we can find any error messages there? What database are you using for Ambari server?

 

Thanks,

Li

Li Wang, Technical Solution Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

Community Guidelines

How to use the forum

Explorer

Hi @lwang .

Thank you for the quick response. I've solved the problem already. I found out that there are hung requests in the Ambari DB specifically on host_role_command which in charge of the Ambari Web UI operation. I remove those hung requests and resolved the problem. My cluster is now running smoothly. Thanks

View solution in original post

Super Collaborator

Hi @TR7_BRYLE ,

 

Great to hear the issue is resolved! Thanks for sharing the solution.

 

Cheers,

Li

Li Wang, Technical Solution Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

Community Guidelines

How to use the forum