Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Unable to upsert data from a csv file into HBase table created via Phoenix

here I am just using a small table to test bulk loading.
I keep getting this error message (attached)!
Is the warning message "unable to load native-hadoop library" the reason?



Expert Contributor

Can you provide the csv file data ? and create table statement?

Looks like data inside csv file may not be correct


p.s. the cells format is "standard"
create table "test" ("nom" varchar, "age" integer, "city" varchar, constraint pk primary key("nom"));

I solved the issue! I found out I needed the right delimiter in my csv file (,)! Plus I think Phoenix is case sensitive (when I wrote the create statement using capital letters for the table's name, it worked!

Expert Contributor

Yeah. I saw displaying ';'

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.