Support Questions
Find answers, ask questions, and share your expertise

Upgrade HDP 3.0.1.0 to HDP 3.1.0: Error in Reading Version Definition File

Hi,

when I try to upgrade from HDP 3.0.1.0 to HDP 3.1.0 I get the following error when using the Version Definition File http://public-repo-1.hortonworks.com/HDP/centos7/3.x/updates/3.1.0.0/HDP-3.1.0.0-78.xml.


"Version Definition read error

An internal system exception occurred: Stack data, Stack HDP 3.1 is not found in Ambari metainfo"


What am I doing wrong ? What is the meaning behindern this internal system error ?


Br,


Dennis

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

I found it out myself. You get the error when you are working with an Ambari Server Version that is not compatible with your HDP. In this case: Ambari 2.7.1 was not compatible with HDP 3.1. So solution was to upgrade Ambari 2.7.1 to Ambari 2.7.3, which is compatible with HDP 3.1, by following the instructions https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.3.0/bk_ambari-upgrade/content/upgrade_ambari.ht.... After restarting Ambari Server and retrying the HDP upgrade process the

"Version Definition read error"

disappeared.


Br,


Dennis

View solution in original post

7 REPLIES 7

Hi,

I found it out myself. You get the error when you are working with an Ambari Server Version that is not compatible with your HDP. In this case: Ambari 2.7.1 was not compatible with HDP 3.1. So solution was to upgrade Ambari 2.7.1 to Ambari 2.7.3, which is compatible with HDP 3.1, by following the instructions https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.3.0/bk_ambari-upgrade/content/upgrade_ambari.ht.... After restarting Ambari Server and retrying the HDP upgrade process the

"Version Definition read error"

disappeared.


Br,


Dennis

View solution in original post

New Contributor

I built Ambari Server 2.7.5 that is compatible with HDP 3.1.

 

During cluster creation in Ambari Web, after entering HDP 3.1 vdf - the following error is issued

 

 Stack HDP 3.1 is not found in Ambari metainfo

 

How to improve that?

 

JK

 

New Contributor

Jans.

 

That is my case too. But I have checked in matrix compatibily that apache ambari 2.7.5  should work with hdp 3.1.0 3.1.4 but this message error appears. "Stack HDP 3.1 is not found in Ambari metainfo"

 

Contributor

Hi

I am facing the same issue , did you find the solution for the above problem

Cloudera Employee

@PrernaU 

 

Ambari 2.7.5 is only fully compatible with HDP 3.1.5, while other HDP 3.1.x or 3.0.x versions are partially compatible for upgrade only. 

 

Please see. 

Cloudera Employee

@fpaezalban Ambari 2.7.5 is only fully compatible with HDP 3.1.5, while other HDP 3.1.x or 3.0.x versions are partially compatible for upgrade only. 

 

Please see. 

Cloudera Employee

@Jans What is the exact HDP version? Ambari 2.7.5 is only fully compatible with HDP 3.1.5, while other HDP 3.1.x version are compatible only for upgrade.