Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Upgrade to CDH 5.5.1 Cloudera Express issues

I am trying to Upgrade CDH 5.4.2 to 5.5.1. I have upgraded CM 5.4.1 to 5.5.1 successfully. My upgrade to CDH5.5.1 is not through, it is stuck with the following error.

 

Checking if the relevant agents are responsive, if the relevant services and hosts are healthy, and if the hosts have the correct software installed on them. Check Again

 The following host(s), dvhdpcdhdn[001-004]uk.dev.global.tesco.org; dvhdpcdhnn[001-002]uk.dev.global.tesco.org; dvhdpcldmr001uk.dev.global.tesco.org, do not have the newly required CDH package installed. They still have the incorrect CDH 5.4.2

 

I am using Cloudera Express edition on a 7Node Hadoop cluster. Please can you let me know the solution if you are already facing this issue.

1 ACCEPTED SOLUTION

Hi Michalis,

Thanks for your advice. I have Migrated from Packages to Parcels, Installed 5.4.2 & then upgraded it to 5.5.1 successfully. the following are the links i have followed:

http://www.cloudera.com/documentation/enterprise/latest/topics/cm_ig_migrating_packages_to_parcels.h...

http://www.cloudera.com/documentation/enterprise/latest/topics/install_upgrade_to_cdh55_parcels.html

 

Thanks a Million

View solution in original post

7 REPLIES 7

Super Collaborator

As the error indicates the listed hosts are still running CDH5.4.2, if you are using Parcels you will have to push the new parcels on the hosts. Use the following docs [1][2] as a guide.

 

hope this helps

 

[1] http://www.cloudera.com/documentation/enterprise/latest/topics/cm_ag_upgrade_cm5.html 

[2] http://www.cloudera.com/documentation/enterprise/latest/topics/install_upgrade_to_cdh55_parcels.html

Hi Michalis - Thanks for replying.

 

I am using Cloudera Express edition. With Cloudera Express edition, I believe that we cannot use parcels for installation. Please confirm this. If we can't resolve this error, the only way out is going to be the manual installation using packages. Let me know if you think this can be resolved/rectified.

Super Collaborator

> With Cloudera Express edition, I believe that we cannot use parcels for installation. Please confirm this.

You can use parcels or packages with Cloudera Express edition.

Listed here [1] are the features compared to Enterprise.

 

[1] http://www.cloudera.com/documentation/enterprise/latest/topics/cm_ig_feature_differences.html

 

I will have this tried on Monday and keep you posted. I have installed using Packages before, Now upgrading to CDH5.5.1 using parcels would be okay? Or do you foresee any challenges

Super Collaborator

> Now upgrading to CDH5.5.1 using parcels would be okay? Or do you foresee any challenges

Please follow the "Migrating from Packages to Parcels" [1] carefully. The documentation is straighforward and I don't forsee any challenges. I am here to help if you get stuck.

 

Thanks Michalis. I will go through the links if I am in any doubt I will revert to you. Thanks Again.

Hi Michalis,

Thanks for your advice. I have Migrated from Packages to Parcels, Installed 5.4.2 & then upgraded it to 5.5.1 successfully. the following are the links i have followed:

http://www.cloudera.com/documentation/enterprise/latest/topics/cm_ig_migrating_packages_to_parcels.h...

http://www.cloudera.com/documentation/enterprise/latest/topics/install_upgrade_to_cdh55_parcels.html

 

Thanks a Million