Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Urgent: upgrading from CDH5.1 to latest version CDH5.2

Solved Go to solution
Highlighted

Urgent: upgrading from CDH5.1 to latest version CDH5.2

Expert Contributor

HI, Cloudera supporter:

 

i am upgrading CDH 5.1 to CDH5.2 following the documentation . currently i have finished CM5.1 to CM5.2 , but the cloudera manager can't start.

 

here is my upgrading steps:

 

1) stop agent, cm service

2) backup mysql database

3) download cm package from http://archive.cloudera.com/cm5/redhat/6/x86_64/cm/5/RPMS/x86_64/  and set local YUM

4) yum upgrade cloudera-*

5) check CM package

 

after the above steps has been completed, but CM can't start now, the error is below:

 

 

Exception in thread "MainThread" java.util.NoSuchElementException: Cannot find management service.
at com.cloudera.api.dao.impl.ServiceManagerDaoImpl.getMgmtService(ServiceManagerDaoImpl.java:539)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at com.cloudera.api.dao.impl.ManagerDaoBase.invoke(ManagerDaoBase.java:208)
at com.sun.proxy.$Proxy80.getMgmtService(Unknown Source)
at com.cloudera.api.v1.impl.MgmtServiceResourceImpl.readService(MgmtServiceResourceImpl.java:41)
at com.cloudera.api.v3.impl.MgmtServiceResourceV3Impl$RoleConfigGroupsResourceWrapper.<init>(MgmtServiceResourceV3Impl.java:37)
at com.cloudera.api.v3.impl.MgmtServiceResourceV3Impl.getRoleConfigGroupsResource(MgmtServiceResourceV3Impl.java:25)
at com.cloudera.cmf.service.upgrade.RemoveBetaFromRCG.upgrade(RemoveBetaFromRCG.java:71)
at com.cloudera.cmf.service.upgrade.AbstractApiAutoUpgradeHandler.upgrade(AbstractApiAutoUpgradeHandler.java:36)
at com.cloudera.cmf.service.upgrade.AutoUpgradeHandlerRegistry.performAutoUpgradesForOneVersion(AutoUpgradeHandlerRegistry.java:233)
at com.cloudera.cmf.service.upgrade.AutoUpgradeHandlerRegistry.performAutoUpgrades(AutoUpgradeHandlerRegistry.java:167)
at com.cloudera.cmf.service.upgrade.AutoUpgradeHandlerRegistry.performAutoUpgrades(AutoUpgradeHandlerRegistry.java:138)
at com.cloudera.server.cmf.Main.run(Main.java:587)
at com.cloudera.server.cmf.Main.main(Main.java:198)

 

 

could you give me some suggestion, thanks very much .

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Urgent: upgrading from CDH5.1 to latest version CDH5.2

Hi,

 

Did you have a management service defined before you did the upgrade? If not, can you try reverting to the older Cloudera Manager binaries, restoring your mysql backup, and adding the management service (there should be a button on the top somewhere), then repeating your upgrade?

 

Thanks,

Darren

View solution in original post

3 REPLIES 3
Highlighted

Re: Urgent: upgrading from CDH5.1 to latest version CDH5.2

Hi,

 

Did you have a management service defined before you did the upgrade? If not, can you try reverting to the older Cloudera Manager binaries, restoring your mysql backup, and adding the management service (there should be a button on the top somewhere), then repeating your upgrade?

 

Thanks,

Darren

View solution in original post

Highlighted

Re: Urgent: upgrading from CDH5.1 to latest version CDH5.2

Expert Contributor

thanks buddy, yes, the upgrading is successful after i added cloudera management service.

 

everything is running ok now except sentry,  it seems it initnalizes the table privileges and database privileges, i am not sure this is a bug or not .  just remind you i have encountered this case. 

 

thanks again. see you .

Highlighted

Re: Urgent: upgrading from CDH5.1 to latest version CDH5.2

Glad that fixed it for you!

I've filed an internal bug report to make the upgrade code handle a missing management service.

I'm not sure why Sentry should have any issue. If you'd like us to take a look, please start a new thread with more information on the problematic behavior and error messages.

Thanks,
Darren
Don't have an account?
Coming from Hortonworks? Activate your account here