Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-06-2025 01:28 AM
Hi,
We have 3 servers VerticaServer, DataLakeNameNode, and DataStageServer. In a DataStage job, we are trying to COPY data into a Vertica table by getting it from external table in DataLake using WEBHDFS. The DataStage job on DR is a copy of production job which is running fine on a daily basis.
I have run following checks to ensure that there are no connectivity issues
1. Ping is working fine between all three servers
2. Telnet from VerticaServer to DataLakeNameNode on port 50070 is working
3. On VerticaServer 'curl -i "http://<IP>:50070/wehdfs/v1/?op=LISTSTATUS"' is returning '200 OK'
4. Webhdfs is up on DataLakeNameNode
In DataStage job, we are getting following error when we run command 'COPY STG.PARTY FROM 'webhdfs://<IP>:50070/warehouse/tablespace/external/hive/STG/PARTY/*' DELIMETER ',' ENCLOSED BY "" NO ESCAPE ABORT ON ERROR'':
"The reported error is: [SQLSTATE 58030] java.sql.SQLException: [Vertica] [VJDBC] (6776) ERROR: Failed to glob [webhdfs://<IP>:50070/warehouse/tablespace/external/hive/STG/PARTY/*] because of error: [http://<IP>:50070/webhdfs/v1/warehouse/tablespace/external/hive/STG/PARTY/?op=LISTSTATUS&user.name=vadmin: Curl Error: Timeout was reached Error Details: Failed to connect to <IP> port 50070: Connection timed out."
I have compared hdfs settings of both Prod and DR on Ambari but there seems to be no difference between them.
Could it be due to environment mismatch? As the same job is working fine on a daily basis on Production.
Would really appreciate the support. Thanks.
Created 02-06-2025 05:35 AM
I also want to know it.
Created 02-06-2025 11:07 PM
@ARK86, Welcome to our community! To help you get the best possible answer, I have tagged in our HDFS experts @Asok @rki_ who may be able to assist you further.
Please feel free to provide any additional information or details about your query, and we hope that you will find a satisfactory solution to your question.
Regards,
Vidya Sargur,Created 02-08-2025 12:56 AM
Thank you Vidya. Looking forward to their response on this.