Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Waiting for Ambari Server to start ........................ERROR: Exiting with exit code 1. REASON: Server not yet listening on port 8080 after 50 seonds.

Highlighted

Waiting for Ambari Server to start ........................ERROR: Exiting with exit code 1. REASON: Server not yet listening on port 8080 after 50 seonds.

New Contributor

Have tried every which way . Ambari Server start error on Virtualbox. new to Hadoop and trying self learning by installing VM and HDP. I have been trying to go past this for days now. Also, when I login to Ambari Server via UI, all the services are showing up with Heartbeat lost. Need help please!

3 REPLIES 3

Re: Waiting for Ambari Server to start ........................ERROR: Exiting with exit code 1. REASON: Server not yet listening on port 8080 after 50 seonds.

Super Mentor

@Sam Mad

If your VirtualBox host does not have enough RAAM / memory allocated to it then it might be running little slow and hence the ambari server startup might be taking little longer than the default time set for it.

The following error just indicates that your Ambari Server is taking slightly more than default 50 Seconds time to open port 8080 and hence you see this message.

REASON: Server not yet listening on http port 8080 after 50 seconds. Exiting.


You should try the following to fix this:

Edit the "/etc/ambari-server/conf/ambari.properties" and increase the following property value to 120 or 150 seconds.

server.startup.web.timeout=120 

Then restart the ambari-server again.

# ambari-server restart

.

Reference: https://issues.apache.org/jira/browse/AMBARI-20220

Also pelase see the"Fixed Issues"section here:https://docs.hortonworks.com/HDPDocuments/Ambari-2.5.2.0/bk_ambari-release-notes/content/ambari_reln... (Search for "AMBARI-20220")

Re: Waiting for Ambari Server to start ........................ERROR: Exiting with exit code 1. REASON: Server not yet listening on port 8080 after 50 seonds.

New Contributor

Unfortunately it didn’t work. I updated the timeout to 150 seconds and still the same issue. Don’t know what are my other options.

Re: Waiting for Ambari Server to start ........................ERROR: Exiting with exit code 1. REASON: Server not yet listening on port 8080 after 50 seonds.

Super Mentor

@Sam Mad

Can you please share the complete "ambari-server.log" and "ambari-server.out" file.

Don't have an account?
Coming from Hortonworks? Activate your account here