Support Questions
Find answers, ask questions, and share your expertise

We are deploying cdh using custom repo. When we are deploying failing in hadoop-kms package.

Solved Go to solution
Highlighted

We are deploying cdh using custom repo. When we are deploying failing in hadoop-kms package.

Explorer

Hi Team,

 

 

We created a local custom repo for cdh and cm and we are deploying. It was failing in hadoop-kms package.

 

When we are doing 'yum repolist' we able to access in all the nodes.

 

I tried installing hadoop kms package using yum utility command 'yum install hadoop-kms*' manually. Getting the same error.

 

Can you please help me out to cdh deployment issue.

 

 

 

END (0)
BEGIN yum -y install hadoop-kms
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package hadoop-kms.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
--> Processing Dependency: hadoop-client = 2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 for package: hadoop-kms-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Running transaction check
---> Package hadoop-client.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
--> Processing Dependency: hadoop-yarn = 2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 for package: hadoop-client-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Processing Dependency: hadoop-mapreduce = 2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 for package: hadoop-client-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Processing Dependency: hadoop-hdfs = 2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 for package: hadoop-client-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Processing Dependency: hadoop-0.20-mapreduce = 2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 for package: hadoop-client-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Processing Dependency: hadoop-0.20-mapreduce = 2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 for package: hadoop-client-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Processing Dependency: hadoop = 2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 for package: hadoop-client-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Processing Dependency: zookeeper for package: hadoop-client-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Processing Dependency: avro-libs for package: hadoop-client-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Running transaction check
---> Package avro-libs.noarch 0:1.7.6+cdh5.4.0+87-1.cdh5.4.0.p0.46.el6 will be installed
---> Package hadoop.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
--> Processing Dependency: parquet for package: hadoop-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
--> Processing Dependency: nc for package: hadoop-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
---> Package hadoop-0.20-mapreduce.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
---> Package hadoop-hdfs.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
---> Package hadoop-mapreduce.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
---> Package hadoop-yarn.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
---> Package zookeeper.x86_64 0:3.4.5+cdh5.4.0+84-1.cdh5.4.0.p0.46.el6 will be installed
--> Running transaction check
---> Package hadoop.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
--> Processing Dependency: nc for package: hadoop-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
---> Package parquet.noarch 0:1.5.0+cdh5.4.0+92-1.cdh5.4.0.p0.48.el6 will be installed
--> Processing Dependency: parquet-format >= 2.1.0 for package: parquet-1.5.0+cdh5.4.0+92-1.cdh5.4.0.p0.48.el6.noarch
--> Running transaction check
---> Package hadoop.x86_64 0:2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6 will be installed
--> Processing Dependency: nc for package: hadoop-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64
---> Package parquet-format.noarch 0:2.1.0+cdh5.4.0+8-1.cdh5.4.0.p0.46.el6 will be installed
--> Finished Dependency Resolution
Error: Package: hadoop-2.6.0+cdh5.4.0+521-1.cdh5.4.0.p0.59.el6.x86_64 (cloudera-cdh5)
Requires: nc
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
END (1)
remote package hadoop-kms could not be installed, giving up
waiting for rollback request

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: We are deploying cdh using custom repo. When we are deploying failing in hadoop-kms package.

Explorer

Hi Team,

 

Problem has been resloved.

 

It was due to 'nc' rpm dependency.

 

We have to install 'nc' package it is os side dependency.

 

Then it started installing. It a dependency hadoop-kms required 'nc' package.

 

 

Thanks

Purna

View solution in original post

2 REPLIES 2
Highlighted

Re: We are deploying cdh using custom repo. When we are deploying failing in hadoop-kms package.

Explorer

Hi Team,

 

Problem has been resloved.

 

It was due to 'nc' rpm dependency.

 

We have to install 'nc' package it is os side dependency.

 

Then it started installing. It a dependency hadoop-kms required 'nc' package.

 

 

Thanks

Purna

View solution in original post

Re: We are deploying cdh using custom repo. When we are deploying failing in hadoop-kms package.

Community Manager

Happy to see that you were able to resolve your issue. Thank you for sharing the solution as others may find it useful as well. :)


Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum
Don't have an account?