Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Web UI for Data Cloud not showing existing VPC, Subnets or SSH Keys



Running HDC on AWS (version 2.0.0) and the UI is not pulling through info from my AWS account which is making it impossible for me to deploy a cluster. The cluster deployment fails with error:

Infrastructure creation failed. Reason: Unrecognized service response for the dry-run request.

Analysis of the trace in log /var/lib/cloudbreak-deployment/cbreak.log shows that the reason for this is that it is trying to deploy into the default VPC for my account which has no subnets and not where I want the nodes to live. This is a showstopper for me right now:

/cbreak_cloudbreak_1 | Caused by: No subnets found for the default VPC 'vpc-XXXXXXXX'. Please specify a subnet. (Service: AmazonEC2; Status Code: 400; Error Code: MissingInput; Request ID: 00b599bd-f7b9-450d-88ea-f0790ceb10f8)

The above shows why i need to specify the VPC and Subnet.

I am very new to Hortonworks and am following the guides for setting this up - - having setup my HDC via the CloudFormation template provided by Hortonworks.

Thanks for the help.



Expert Contributor

Where are you getting the information that you are using 2.0.0 from? Can you click the cog on the top right and click 'About'? What version does it say there? I just spun up an HDCloud using the github link and it says 1.16.5. Want to make sure it is the same for you.



Thanks for the response @anarasimham. I got the 2.0.0 from the bottom left hand corner of the Cloud Controller Web UI. I have since destroyed the stack so cannot confirm via your request above - i will spin up a new instance and confirm. For reference i was using the Advance Deployment Cloud Formation template which also shows 2.0.0 in the title -




@anarasimham confirmed that the CF Template installs HDC 2.0.0 (see image). Do you know if there is a CF template for the 1.6 still available?

Expert Contributor

Hi Andy,

I tried installing 2.0.0 as well, and it is working for me. I can see a list of all VPCs in my account. Is this a permissions issue within your AWS configuration? Is it something else inside of AWS - are you launching the HDCloud stack in the same region as where you have your VPCs defined? You will not see your VPCs if you are launching HDCloud in a separate region from where you usually do your work. Make sure you click the right HDCloud link for your region:

Hi @Andy Kelly,

if you are starting from scratch, I would encourage you to use the supported 1.16.5 version of HDCloud instead of the technical preview 2.0. 1.16.5 is available here:



I just deployed a 1.16.5 version as per your suggestion - thank you for the link as i couldn't find that. The issue is exactly the same in this release too - none of the fields from AWS are in the UI (SSH Key to use, Subnet ID or VPC ID).

I have tried using the CLI to create the cluster but receive the error:

panic: runtime error: slice bounds out of range [recovered]

Please advise.





Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.