Support Questions
Find answers, ask questions, and share your expertise

What version of HDF has been used for this tutorial (https://hortonworks.com/tutorial/realtime-event-processing-in-hadoop-with-nifi-kafka-and-storm/)?

New Contributor

Hello

We were trying out tutorial (https://hortonworks.com/tutorial/realtime-event-processing-in-hadoop-with-nifi-kafka-and-storm/) to learn basics of Hortonworks Dataflow . The Nifi dataflow part and Kafka part works fine . But when storm throws some error . We have concluded that it is some version dependency problem . So we wanted to know the HDF version used in tutorial (https://hortonworks.com/tutorial/realtime-event-processing-in-hadoop-with-nifi-kafka-and-storm/) . Please specify it !!

Thanks

5 REPLIES 5

Contributor

@Abhay Singh

The tutorial is using HDF-2.1.0 which is an older version.

You can download this from the archive section on this page: https://hortonworks.com/downloads/#sandbox

43618-screen-shot-2017-11-16-at-95855-am.png

New Contributor

Ramya Jayathirtha

i tried HDF 2.1.0 but it doesn't have HBase , Hive , HDFS and lots of other services . I tried adding these services from Add Service button of Ambari Dashboard but these service are not even listed there !!

I think it has some other version installed .

Explorer

You can try using any newer version like 3.0

New Contributor

@Ramya Jayathirtha

HDF 3.1 also doesn't have Hbase installed, or option to install it.

Any suggestions how to install any version with NiFi , Kafka, Storm and HBase on it?


Thanks

Super Guru

Download HDF 3.1

HDF will never have HBase.

HBase requires the infrastructure of HDP.

Download HDP 2.6 and you can combine HDF and HDP to have all your purposes.

HDP 2.6 has Kafka, Storm and HBase. You can easily add NiFi to that.

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.5/bk_ambari-installation/content/ch_Getting_R...

then add nifi

https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.1.1/bk_installing-hdf-and-hdp/content/ch_instal...