Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-23-2021 12:48 PM - edited 09-16-2022 07:43 AM
Hi experts:
We are on the version Cloudera CDH-6.3.4. When users exit from login nodes, we see the error appearing in /var/log/messages from time to time:
Sep 23 15:06:37 hlog-2 cm: Process Process-10786: Sep 23 15:06:37 hlog-2 cm: Traceback (most recent call last): Sep 23 15:06:37 hlog-2 cm: File "/usr/lib64/python2.7/multiprocessing/process.py", line 258, in _bootstrap Sep 23 15:06:37 hlog-2 cm: self.run() Sep 23 15:06:37 hlog-2 cm: File "/usr/lib64/python2.7/multiprocessing/process.py", line 114, in run Sep 23 15:06:37 hlog-2 cm: self._target(*self._args, **self._kwargs) Sep 23 15:06:37 hlog-2 cm: File "/opt/cloudera/cm-agent/lib/python2.7/site-packages/cmf/monitor/host/filesystem_map.py", line 27, in disk_usage_wrapper Sep 23 15:06:37 hlog-2 cm: usage = psutil.disk_usage(p) Sep 23 15:06:37 hlog-2 cm: File "/opt/cloudera/cm-agent/lib/python2.7/site-packages/psutil/__init__.py", line 1947, in disk_usage Sep 23 15:06:37 hlog-2 cm: return _psplatform.disk_usage(path) Sep 23 15:06:37 hlog-2 cm: File "/opt/cloudera/cm-agent/lib/python2.7/site-packages/psutil/_psposix.py", line 131, in disk_usage Sep 23 15:06:37 hlog-2 cm: st = os.statvfs(path) Sep 23 15:06:37 hlog-2 cm: OSError: [Errno 2] No such file or directory: '/run/user/3336512'
It seems that the error does not cause any harm. But it is annoying. We are on Red Hat Enterprise 7.8. Any suggestions on how to fix this are very welcome!
Thanks, Vincent.
Created 09-24-2021 06:57 AM
@vincentD To suppress this error, update the /etc/cloudera-scm-agent/config.ini on each of the hosts affected to:
1. In the line that lists the nodev filesystems:
# The list of non-device (nodev) filesystem types which will be monitored.
monitored_nodev_filesystem_types=nfs,nfs4,tmpfs
2. Please change the uncommented line to read as :
monitored_nodev_filesystem_types=nfs,nfs4
3. Restart the cloudera manager agent with:
service cloudera-scm-agent restart
Hope this helps.
Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Created 09-27-2021 11:16 AM
Hi Chelia,
The fix does make sense. Thank you. Since we are here, can I ask another question: when we want to upgrade our Cloudera CDH-6.3.4, what is the newer software version that we could upgrade to, and hopefully will run on RHEL 8.x? Thanks again!
Regards, Vincent
Created 10-06-2021 08:34 AM
@vincentD I hope it helped to resolve your issue, Regarding your query on upgrading CDH 6.3.4 to new software version.
Please explore the below CDP Path.
https://docs.cloudera.com/cdp-private-cloud-upgrade/latest/release-guide/topics/cdpdc-release-notes-...
https://docs.cloudera.com/cdp-private-cloud-upgrade/latest/release-guide/topics/cm-cdh-runtime-versi...
https://docs.cloudera.com/cdp-private-cloud/latest/release-summaries/topics/announcement-202108-717....
https://docs.cloudera.com/cdp-private-cloud/latest/index.html
Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.