Support Questions

Find answers, ask questions, and share your expertise

When using storm-kafka version 1.1.0.2.6.0.3-8 it has a dependency on kafka-clients version 0.10.0.2.5.2.0-70 which doesn't even exist

Why it even uses a different version of HDP? I found this jar in a nexus-private repository, but I assume this is an error, isn't it?

What version do I need to include to deploy a topology to a 2.6.0.3-8 HDP cluster and have the Kafka Spout Lag in the UI?

1 ACCEPTED SOLUTION

@Lester Martin

Work around is to add the following in your pom.xml

<dependency>
                <groupId>org.apache.storm</groupId>
                <artifactId>storm-kafka-clients</artifactId>
                <version>1.1.0.2.6.0.3-8</version>
                <exclusions>
                    <exclusion>
                        <groupId>org.apache.kafka</groupId>
                        <artifactId>kafka-clients</artifactId>
                    </exclusion>
                </exclusions>
            </dependency>
            <dependency>
                <groupId>org.apache.kafka</groupId>
                <artifactId>kafka-clients</groupId>
                <version>0.10.0.2.6.0.0-598</version>
             </dependency>

View solution in original post

4 REPLIES 4

I surely don't have an answer for this one, but you could ~play~ with it by hand-jamming what you think is the appropriate jar into the worker nodes as I did with another jar issue as described in https://martin.atlassian.net/wiki/x/JbXqBQ. Then you'd have an easy case to submit which the support team could easily reproduce (and get fixed!). Good luck and happy Hadooping/Storming.

Ahhh.... for my sins it looks like I ran into the same problem as you did, @Joan Viladrosa (shown below). Did you get anywhere with this? Do you have a workaround while I try to see if anyone knows what's up?

15977-jarissue.jpg

@Lester Martin

Work around is to add the following in your pom.xml

<dependency>
                <groupId>org.apache.storm</groupId>
                <artifactId>storm-kafka-clients</artifactId>
                <version>1.1.0.2.6.0.3-8</version>
                <exclusions>
                    <exclusion>
                        <groupId>org.apache.kafka</groupId>
                        <artifactId>kafka-clients</artifactId>
                    </exclusion>
                </exclusions>
            </dependency>
            <dependency>
                <groupId>org.apache.kafka</groupId>
                <artifactId>kafka-clients</groupId>
                <version>0.10.0.2.6.0.0-598</version>
             </dependency>

It did the trick for me. I sure hope it helps out @Joan Viladrosa, too! Thanks, Sriharsha!

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.