Support Questions
Find answers, ask questions, and share your expertise

While Loading data into hive table user is getting error.

Erro

===============================================================================================

Loading data to table vau.vau_multi_issr_mnthly_mrch_participation partition (cpd_dt=20180630)

FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.MoveTask. Unable to move source hdfs://nameservice1/hive/vau.db/vau_multi_issr_mnthly_mrch_participation/cpd_dt=20180630/.hive-staging_hive_2018-07-26_11-06-28_809_8487593963319586229-1/-ext-10000 to destination hdfs://nameservice1/hive/vau.db/vau_multi_issr_mnthly_mrch_participation/cpd_dt=20180630

===============================================================================================

Command

===============================================================================================

insert overwrite table vau_multi_issr_mnthly_mrch_participation partition (cpd_dt=20180630)

select

concat_ws(':',cast (temp2.ua_mult_issr_id as string),temp2.ua_mult_issr_nm,

concat_ws('~',collect_list(concat_ws('|',cast(temp1.ua_issr_seg_id as string),

temp1.ua_issr_seg_nm,

cast(temp1.ua_issr_id as string),

temp1.ua_issr_nm,

cast(temp1.ua_bin as string),

cast(temp2.regn_cd as string),

cast(temp2.regn_nm as string),

cast(temp2.ctry_cd as string),

cast(temp2.ctry_nm as string),

cast(temp1.enrl_dt as string),

cast(rpt_fmt_ind as string),

lpad(cast(coalesce(vol_bus_id, '') as string), 8, '0'))))) as arr1

from

vau_multi_issr_mnthly_mrch_participation_temp1 temp1

inner join

vau_multi_issr_mnthly_mrch_participation_temp2 temp2

on

temp1.ua_issr_seg_id = temp2.ua_issr_seg_id

group by

temp2.ua_mult_issr_id,temp2.ua_mult_issr_nm;

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Vinicious,

Thanks for you help. Pls note issue is resolved now there was issue with hive staging directory. Permission was 777.

Reagrds

Mohammad Shamim

View solution in original post

3 REPLIES 3

Hi @Mohammad Shamim!
Could you confirm if the user has permission on that directory?
or is there any space quota set?

Otherwise, try to enable the debug for the logs:

hive --hiveconf hive.root.logger=DEBUG,console

Hope this helps!

Hi Vinicious,

Thanks for you help. Pls note issue is resolved now there was issue with hive staging directory. Permission was 777.

Reagrds

Mohammad Shamim

View solution in original post

Good to know @Mohammad Shamim!
Please if the issue is solved, I'd kindly ask you to accept the answer. This will help the other HCC users to find the best answer faster and will encourage the other users to keep doing a good job as well 🙂