Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Why Ambari-Blueprint is setting the security.inter.broker.protocol of kafka to PLAINTEXTSASL instead of SASL_SSL?

Highlighted

Why Ambari-Blueprint is setting the security.inter.broker.protocol of kafka to PLAINTEXTSASL instead of SASL_SSL?

Hello,

When using an Ambari blueprint to change the Kafka property security.inter.broker.protocol.
I am able to change other properties during deployment, but it seems that this property always defaults to PLAINTEXTSASL.

Actual configuration,

{ "kafka-broker": { "properties": { "listeners": "PLAINTEXTSASL://localhost:6668", "security.inter.broker.protocol": "SASL_SSL" } } }

Is there a BUG in Ambari-2.2.2? If yes in which version this is fixed.

1 REPLY 1

Re: Why Ambari-Blueprint is setting the security.inter.broker.protocol of kafka to PLAINTEXTSASL instead of SASL_SSL?